Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There's a web site I visit that includes a document which is returned with content type text/plain and my version of Google Chrome used to display it in the browser window, as plain text. I like it that way. However, it has started to download the document now when I visit it, instead, meaning I have to open it with a text editor to view it. How can I make Chrome return to the old behaviour?

share|improve this question
Try clearing your temp files and cache. – random Apr 1 '10 at 8:27
Are you sure other browsers don't download it as well? The server might tell them to do so. Peek into the headers using the Web Inspector. Or give us a URL? – Arjan Apr 1 '10 at 8:55

The reason is most likely that the server is telling the client (browser) to download the file. This is controlled (usually) via the HTTP header

Content-disposition: attachment

(optionally with a filename).

Check if the server serves your document with this header. To view the headers, you can download the page using a tool that preserves HTTP headers (e.g. wget --save-headers), or use an online service, e.g. .

Then post the headers here, or even better, the document's URL (if you can).

share|improve this answer
So, assuming this is the case, how can you have the browser ignore this option and simply display the file instead of trying to save it? – Andrew Case Sep 18 '13 at 18:56
Answer to my own question:… – Andrew Case Sep 18 '13 at 18:58

Can you verify that the Content-Type is actually 'text/plain'? You can do so in by going to View -> Developer -> Developer Tools and viewing the response headers on the file. I've seen situations where the Content-Type is unrecognized (i.e. 'plain/text'), and therefore causes the file to be downloaded rather than displayed.

share|improve this answer

You could try doing


Which should let you see the document in chrome regardless of the headers

share|improve this answer
Nope. I just tried that. – nalply Oct 9 '11 at 15:24
I think this trick only works in Firefox. – Mechanical snail Jul 16 '12 at 23:33
Works just fine in Chrome (24). – Stefan Seidel Jan 25 '13 at 10:41

I strongly recommend that you check your url with other browser if it's working so may be you are facing this google Chrome issue
Here is an example URL showing the issue:
Try this URL with Firefox, then Chrome and you'll see the behavior is different because of the hidden "^G": test^Gtext.

If your text is utf-8 encoded but has some lower-ascii chars in it (e.g., ESC) that might be triggering the issue.

If other browsers act the same as Chrome you have to check if the MIME type really is plain/text, use a web sniffer to verify the header content. Just do a "CTRL + SHIFT + i" in Chrome, then go to the "Network" tab.

share|improve this answer

What Chrome plugins do you have installed? There is a similar question on SO:

The solution was an issue with this plugin:

I've solved the problem! It was caused by the Webug 1.2.3 FirePHP extension for Google Chrome. Don't know if future versions of this plugin also have this bug.

share|improve this answer

You must log in to answer this question.