Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After updating Mac OS X to 10.6.3 the arrow keys do not work in MC anymore - instead of moving the cursor it types, for instance, B for down key, C for right key. Although, if I quit MC and try it in terminal, it works.

Has anyone experienced this problem? Is there any solution for this?

share|improve this question

migrated from Apr 1 '10 at 11:29

This question came from our site for professional and enthusiast programmers.

Not very programming related, is it? – Manrico Corazzi Apr 1 '10 at 9:35

I had the same problem and just solved it. For me, it was not libncurses -- I tried libncurses from Mac OS X 10.6.2 and I also tried GNU ncurses (compiled GNU ncurses and subsequently and re-compiled and linked Midnight Commander (4.7.1) against the GNU ncurses). Both attempt were futile.

I even changed the, which did not solve my problem either.

Finally, I simply removed the preferences file for Quit, delete ~/Library/Preferences/, launch and start Midnight Commander. For me, this worked like a charm :-)

I tracked the problem down a bit further. In Terminal's preferences I usually make a copy of the "Pro" settings and make two modifications to "Pro Copy": I set the background to solid black (instead of black transparent) and I want the window to close when the shell exits. Whenever I make these two changes, the cursor keys become incredibly slow in Midnight Commander. As long as I use the standard "Pro" settings, MC works fine.

share|improve this answer

Or just use this: - MC version 4.7

share|improve this answer
This solution has worked fine for me, the new MC has no problems with arrow keys on Mac. – CrazyCoder May 6 '10 at 21:44

It seems Apple broke the built-in ncurses (a library used by terminal-based tools that repaint the full terminal screen). If you built MC via Fink or MacPorts, there are probably adjustments you can make to the build environment to make sure it links against the Fink or MacPorts version of ncurses, instead of the system version of ncurses.

More information here:

...or Google 10.6.3 ncurses.

share|improve this answer

Copying /usr/lib/libncurses.5.4.dylib from a 10.6.5 machine to the 10.6.3 machine solved the problem for me.

(This was done as a quick fix to get a specific ncurses program -- namely CGSecurity's TestDisk -- to work. Of course upgrading to 10.6.5 might be a good idea regardless.)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.