Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a HP LP3065 that requires a dual link dvi cable to go up to 2560x1600 resolution. However, I do not have that cable, but I want to use 1920x1200 resolution. However, my nVidia Display Settings (also system display settings) will only go up to 1280x1024, which looks horribly pixelated on the 30".

How do I force the 1920x1200 resolution? I tried adding the mode into my xorg.conf file, but it still would not take it. I know my vid card can do 1920x1200 since it works on the 24" monitor with the same dvi cable.

Here are my specs: Fedora 12 Nvidia Quadro NVS 420 Intel Xenon E5530 cpu 6gig memory

Thanks

share|improve this question
    
what kind of distribution do you use ? which driver ? which desktop manager ? –  LB40 Apr 1 '10 at 14:15
    
driver is from rpmfusion, the metapackage for nvidia, gnome desktop, fedora 12 (constantine) –  hi. Apr 1 '10 at 14:26

1 Answer 1

This looks somewhat like the kind of problem I used to have on Ubuntu. It is basically like this: you set a resolution in Xorg.conf, but due to the monitor sending a bad EDID signal to your graphics card, the card cannot read the allowed parameters for the monitor, especially the refresh rates. So the driver just defaults to some predefined mode, a kind of a lowest common denominator (my max res was 640x480 only! that's why I'm not sure if it is the same) instead of using the one defined in Xorg.conf. It then ignores everything you define about resolution too.

I cannot tell you if this is the same problem, but it is worth trying out. If it isn't, try to diagnose it better. Go to the X.org log file (I don't know where it is located on fedora, should be easy to find it). Check if for any warnings (lines starting with (WW)) or errors (lines starting with (EE)) where the line itself says something about graphics. If you get such a message, especially an EE, google it, you'll often find that somebody has found a way to fix it.

If your problem turns out to be the same as mine, here is how to fix it. Edit Xorg.conf and put correct values to your Monitor section. Something like this: Section "Monitor" Identifier "LP3065" HorizSync 48-49 VertRefresh 55-65 EndSection Be sure that Identifier is same as the Monitor line in Screen section. Be careful with the values. The correct ones should be listed in your monitor's TFM, but often they aren't there. Google for them, and if you don't find them, try to use values somebody else has already tried. I've read warnings of possible monitor damage if you set the values too high, but in reality, never read somebody say it happened to them (I've used values I found on the Internet, too). Proceed at your own risk.

What I've had was that setting the rates to something not supported by the monitor resulted in no signal being sent to the monitor at all. So if you start dabbling there, you should be prepared to eventually replace your Xorg.conf from a backup without being able to see anything if started in normal mode (so you should know how to use recovery mode, or how to remote into the system from another PC, or be able to boot from another OS install which supports the file system on your non-encrypted fedora partition. And you should make a backup!).

Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.