Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I get my media player to open when clicking an .MP3 link in Internet Explorer?

It used to do this, but now it just starts downloading the file before playing it.

Edit - None of the suggestions work. The Media Player is and has always been associated with .MP3 files. I did install iTunes to access the Apple Developer Network, and I believe that's the point where it stopped working, however, .MP3 files are still associated with Media Player. I can find no reason under the sun for the file to just start downloading instead of opening when clicking an .MP3 link. Perhaps it's the server that doesn't stream the content? It should as it is in HTTP link.

Edit - IE8

share|improve this question
    
What version of IE? –  random Jul 25 '09 at 6:38
    
What version of Windows? –  Factor Mystic Aug 10 '09 at 4:07
add comment

3 Answers 3

Previous answers are just flitting around the problem. Go back into your filetypes list:

My Computer » Tools » Folder Options... » File Types

Browse to MP3, then select Advanced. Then make sure "Confirm open after download" is selected. Hopefully, your prompt will come up again. From there, you can choose to open or save the MP3 file again.

You'd probably want to first unselect "Always ask before opening this type of file" before you select Open. That way, it'll remember your Open action and stop asking for the prompt again.

Of course, if you ever change your mind, you can go back re-check the "Confirm open after download" checkbox in File Types.

share|improve this answer
add comment

The windows system uses a system wide file association as described on this Wikipedia page.
To associate your media player with the MP3 files,
you can do the same editing the MP3 file type at,

My Computer ==> Tools ==> Folder Options ==> File Types.

Alternatively, I think, you should also be able to setup the same association by [right-click] on a MP3 file in the Explorer window (not IE) and selecting the [Open With] option to choose media player -- just click on the "Always use this program" button at the bottom to create the association.

share|improve this answer
add comment

Try doing the following in Windows Media Player:

ALT-key > Tools > Options > Select All (or make your selection)

If you don't want to change the selection, then just check/uncheck 1 box so that the "Apply" button activates.

Press Apply / OK > Close Windows Media Player

Now try and play .mp3 files directly in Internet Explorer. Let med know if this helps, it did for me on IE8.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.