Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some problems setting up a new wireless PCI card on a WinXP SP3 PC.

I know that the router is configured correctly. It is a Linksys WRT54GL, using 802.11b/g. Security mode is WPA2 Personal with TKIP+AES encryption. I am able to connect to this fine using my laptop (first gen MacBook with a 802.11g built in card).

The new PCI card is also Linksys, but it supports 802.11n. Card seems to be installed ok (Windows sees it fine, doesn't list any errors in Device Manager), however when it scans for available wireless networks it can't find my wireless network (the router is set to broadcast the SSID).

I tried to enter the network SSID manually, but that didn't seem to help. I chose WPA2-PSK for network authentication. The only options for encryption are TKIP or AES - I've tried both, neither worked. I am sure that I typed in my wireless key correctly.

At this point, I don't think the problem is with encryption, but something else. It almost seems like I need to switch the wireless card into g mode, but I haven't found a way to do that (if that is even possible/necessary - I thought n was fully backwards compatible with g).

Also, the PC is in the same room as the router, and my laptop, so I don't think that it is an interference issue.

Any ideas what I'm doing wrong? I'm running out of things to try at this point. :(

Update, to answer Spiff's questions:

  • The antennas are connected and outside of the case, although the back of the PC case is away from the router. Don't think that should matter, though.
  • I didn't try putting the PCI card in ad hoc mode. I'll try that in the morning, and update here.
  • Both the MacBook and the PCI card are from the US.
  • I'll try a different channel and no encryption, and update here.
  • Using factory-standard firmware.

Update 2:

  • Wireless card can't connect on channels 1, 11, and 6 (my router was originally set to 6). I didn't see an option to set the channel on the card, only to turn on/off auto channel select (which was disabled, enabling didn't change anything). I was in the properties for the card itself (right click wireless connection, Properties, press Configure, click on Advanced tab).
  • Disabling encryption didn't help.
  • How do I connect to the PC via ad hoc mode? Do I scan for wireless networks on the MacBook, to see if the PC shows up in the list?
share|improve this question
    
Does the card see any networks at all? –  goblinbox Apr 2 '10 at 22:29
    
@goblinbox - I don't have the ability to test other routers, if that is what you're asking. –  Andy Apr 3 '10 at 0:14
add comment

2 Answers 2

Sorry to ask this, but is there any chance you forgot to attach the antenna array to the back of the PCI card? Are the antennas out in the open and not inside your enclosure?

Did you try putting the PCI card into IBSS (a.k.a. "ad hoc", "computer to computer") network mode, or software access point mode, and see if you can see it from the MacBook?

By the way, a 1st gen MacBook from 2006 has an a/b/g card, unless you meant a 1st gen iBook from 1999.

Is there any chance your equipment is from two different regulatory domains? If the AP and MacBook are both from Europe, you could have them on channel 12 or 13, but if the PCI card is from the US or Canada, it may not support those two channels.

You know what? You should try a different channel anyway. There could be an internal interference source inside your PC enclosure that's hurting part of the band. Try channel 1, then try channel 11.

I'd also temporarily try no encryption just in case.

Are you running Wi-Fi certified firmware on your AP? Open source firmware projects like DD-WRT and Tomato never go through Wi-Fi interoperability certification, so their level of correctness is an unknown quantity.

share|improve this answer
    
Updated my question with answers to your questions. I'll try a few things in the morning (when I'm not tired), and let you know how it goes. –  Andy Apr 2 '10 at 4:29
    
Updated my question with additional findings. Changing channels and disabling encryption didn't help. Could you explain how I can connect to the PC from my MacBook using ad hoc mode? –  Andy Apr 2 '10 at 21:46
    
Unfortunately, I'm not enough of a Windows guy to walk you through how to tell Windows (or the Linksys software that came with your PCI card) to create a wireless network. But if you're able to figure that end out, the Mac side is easy, just pull down the AirPort menu and see if the name of your Windows machine's newly-created wireless network shows up in the list of networks. –  Spiff Apr 4 '10 at 10:00
add comment
up vote 0 down vote accepted

We finally got the wireless card working today. When it was moved to another PCI slot, it could see (and connect) to the wireless network. I don't think that the original slot is bad (since it previously had a video card connected there), but it works now so I'm not going to worry about it too much.

Thanks for all the suggestions. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.