Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Have you seen anything like this before?

alt text

Not always but permanently shows up this strange behaviour. What's the name of that problem? And - ofcoz:) - how can I solve it?

I tried:

  • driver update
  • full driver/app unsintall and Lenovo ThingVantage System Update
  • turning aero off (... and everything works fine)
  • monitor driver update (but only generic PNP monitor found)

Configuration:

  • Lenovo Thinkpad T400s (was Vista but clean Windows 7 install now) (update: this is not a lenovo specific error)
  • Windows 7 Professional (ENG)
  • Mobile Inter 45 Express (WDDM 1.1)

Update

I found the 'correct' name: visual corruption.

The problem appears when VT-d technology is enabled (ie. for VPC). Turn off and hopfully everything will work fine. Details: http://forums.lenovo.com/t5/Windows-7-Discussion/Bizarre-screen-artifacts-on-R400-Integrated-Graphics-running-Win/m-p/199594. In short: goto BIOS and disable it.

Update II

Just for google:) It's hard to characterize the problem so there are some keywords for it:

areo, glitches, pixel, bug, visual corruption, garbled textures, frame error, virtualization, vt-d

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I would advise you to check the current temperature of your GPU, when this happens. You can use something like Speedfan (or another recommended at this other question).

To me, it looks like artifacts which occurs when the graphical card is heating too much. Since Aero is relying on more advanced graphics than a regular desktop display, it could explain why such thing happens only with it. This thought is also seconded by the fact that you report such problem happening only from time to time.

For information, you can find examples of such graphical glitches happening at this link (too big images to copy here).

share|improve this answer
1  
thank you, the last link helped to solve the problem! edited my post to clarify. –  boj Apr 2 '10 at 10:08
1  
@boj - my answer only pointed you in good direction, it doesn't actually answer the problem. You should write the answer yourself, with exactly what fixed it, and accept it (you can't accept your own answer before 2 days, though). It would make it probably more clear. Finally, my answer is only about heat, nothing really linked. –  Gnoupi Apr 2 '10 at 12:54

I've had exactly the same problem with my Dell Latitude XT-2. See here. And yes, it was the same underlying issue.

share|improve this answer
    
thanx, I'll collect the adjectives in my post to help others find it. –  boj Apr 2 '10 at 12:42
    
Somehow I have doubts that the words in your post will do anything to make it more findable. –  Joey Apr 2 '10 at 14:50

Apparently this happens if you use a mismatched (1GB + 2GB) pair of memory modules. Lenovo has a support page for the problem:

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-74739&selectarea=SUPPORT&tempselected=5

I have the exact same problem and VD-t off solves it. Cheaper than upgrading to 4GB of RAM. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.