Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I ssh into my Debian Lenny server and open a man page, single quotes appear to be messed up. Example from the man page of apt-get:

If no package matches the given expression and the expression contains one of ´.´, ´?´ or ´*´ then it is assumed to be a POSIX regular expression, and it is applied to all package names in the database. Any matches are then installed (or
removed). Note that matching is done by substring so ´lo.*´ matches ´how-lo´ and ´lowest´. If this is undesired, anchor the regular expression with a ´^´ or ´$´
character, or create a more specific regular expression.

I'm on Mac OS X and using xterm. If I use Terminal, the problem doesn't happen.

My locale is configured correctly as far as I can see:

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

The problem doesn't happen locally. Displaying man pages via xterm on Mac OS X works just fine.

I don't have any special configuration files for xterm. I'm using the default settings.

I'm not sure what's wrong with my environment, and I have no idea what to check next. I'd appreciate help.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I managed to fix the issue by adding the following to my .bash_profile in Mac OS X:

export LC_CTYPE=en_US.UTF-8
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.