Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my home network , i have dd-wrt router in another room , which bridges wifi from main home router (linksys) to the computers wired behind dd-wrt router.

Now I cannot ssh from my laptop ( connected to linksys wifi) to the computers behind dd-wrt wifi bridge. I am able to ping the individual computers behind the dd-wrt bridge. When it comes to ssh or telnet to the computers , it is blocked.

What can I do to make dd-wrt bridge to open up all ports in the dd-wrt bridge ?

share|improve this question

2 Answers 2

You probably have to enable port forwarding on the dd-wrt router in order to SSH to the computer behind it. You could also check any firewall settings on the other computer to make sure that the ports aren't being blocked, though if it responds to pings I doubt that is the issue.

share|improve this answer
    
@Jayaraman, to check the firewall go to Security -> Firewall -> Firewall protection -> SPI firewall -> Disable. I have a Client Bridge setup as well and this is Enabled by default. –  hyperslug Apr 3 '10 at 19:23
2  
I sure hope @hyperslug is right and @JoshK is wrong, because I'd be severely disappointed in the dd-wrt people if they called it "bridging" when it was actually NATting. And even then, it's kinda weird to have a layer-2 device (a bridge) doing things at higher layers (firewalling based on attributes at layers 3 and 4). –  Spiff Apr 4 '10 at 9:31

Recommend the remote DD-WRT device be used in Bridge-Repeater mode. This would ensure that all devices are playing on the same field.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.