Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently noticed wmpnetwk.exe using a more than usual amount of processor cycles.

I'm on Windows 7 Home Premium on a Netbook.

I'm guessing it's a feature of Windows Media player that recently got turned on, possibly because of a Windows update or accidental key combination.

I don't usually use Media player that often.

Does anyone know if it is a feature that has recently turned on, and if so, how do I turn it off ?

Someimtes, like this morning, my netbook seems to be taking longer to boot up, or freezing around the login screen.

share|improve this question

2 Answers 2

This is due to the windows media player network sharing service using resources.

  • Run "services.msc" (Ok, or Start | Control panel | Administrative Tools | Services)
  • Scroll down to "Windows media player network sharing"
  • Double click and under startup type set to disabled
share|improve this answer

I had this problem and after hours of reading how to shut down the service, (I need it running so I can stream media) managed to fix it. The problem reportably has 2 root causes, and I believe a third issue comes into play.

a) Corrupt AVI files (not the problem I had)

b) Index from too high in the file system tress. Apperently it adds a notify on change event to the folder. So any file change can cause it to reindex, including the swap file or temporary files it is changing.

c) Unconfirmed, but possibly related to aabove, is corrupt files for media Player.

Based on this I did the following, and it did fix my problem.

a) Deleted all .avi files (I don't use them, but a) should have this effect as far as wmpnetwk.exe is concerned.)

b) Removed all libraries from Media Centre.

c) Stop the wmpnetwk.exe process. Go to C:\Users\\AppData\Local\Microsoft\Media Player, and delete all the files. (Back them up first). I just renamed the media Player folder.

d) Reboot the computer.

This fixed my problem. I then added libraries a few at a time to make sure I didn't break it again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.