Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi I am using a BlacX Duet HDD Docking Station to connect a 1TB WD Caviar Black SATA HDD (WD10000LSRTL) and a HITACHI SATA DESKSTAR (0S00163) to my G51VX (BestBuy) laptop via the eSATA port.

When I plug in both HDDs in to the Docking Station, connect the docking station to my laptop and start Windows 7 (64-bit Ultimate), only the HDD in the first drive in the port actually shows up in My Computer and Disk Management.

If I swap the drives positions I can get them both to work, but never at the same time.

I also checked in the bios settings on the laptop, under Advanced->IDE Configuration->SATA Operation Mode, and it displays:

SATA Operation Mode: [Enhanced]

AHCI Port0 [Hard Disk]
Device: Hard Disk
Vendor: ST9320421AS
LBA Mode: Supported
S.M.A.R.T.: Supported

AHCI Port5 [Hard Disk]
Device: Hard Disk
Vendor: Hitachi HDS721010CLA332
Size: 100.00 GB
LBA Mode: Supported
S.M.A.R.T.: Supported

There should be a third drive, but I'm not certain why it is not being picked up. Additionally, before I played around with the settings in the IDE configuration, it used to display the DVD as well.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Okay figured it out.

My laptop uses a ICH9M-E/M Chipset and this does not have a "port multiplier". The BlacX Duet HDD Docking Station only supports using both drives when the motherboard/chipset in question contains a "Port Multiplier"

But it's not a total loss. I can still use both drives using USB at slower speeds, and I can also disconnect them in Windows and reconnect them using the eSATA connection by disconnecting the hardware.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.