Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an odd issue with a Netgear WIFI router, 4 computers, 2 pc laptops with XP and 7 installed, one MacBook Pro and one older Mac mini.

With security off everything can connect to the wifi.

With WPA-Security on only the Macs can connect to the wifi.

I've reset the Netgear router, done everything again from scratch, no deal. The PCs just can't connect. One of the laptops can connect to another Netgear router in a different location. The PCs can connect to other wifi networks just fine so the laptop PC hardware is fine.

share|improve this question
    
Are you using WPS to configure the network? –  Fred Apr 5 '10 at 20:20
1  
Is the Netgear 802.11 router actually Wi-Fi certified? Do you have up-to-date firmware on it? Are the PC laptops' 802.11 cards Wi-Fi certified? Do you have up-to-date drivers on them? Also, please "name and shame" the exact AP and client card makes/models and firmware/driver versions you're having trouble with. –  Spiff Apr 5 '10 at 21:00
    
@Fred, What is wps? –  jfar Apr 5 '10 at 21:13
    
@jfar WPS is "Wi-Fi Protected Setup", which is a scheme the Wi-Fi Alliance came up with to try to make it easier to get new devices onto a WPA-protected Wi-Fi network, for people who aren't good at entering WPA passphrases correctly on their clients (or for client devices that don't have good screens and keyboards for entering WPA passphrases with). Even if you have a WPS-enabled Wi-Fi router, you can still use the traditional method (i.e. select WPA-PSK, enter passphrase) for getting your Windows laptops onto the network. But WPS might save you a step. –  Spiff Apr 6 '10 at 1:37

2 Answers 2

if the router has same ssid as your previous wep settings then windows might remeber the old settings for the network. also u might want to change security settings under windows from actual wep to wpa and then tkip option.

share|improve this answer
    
Elaborating on this: in addition to resetting your router, try resetting your Windows' WiFi configuration by renaming the SSID as said above and deleting any configuration on your Windows machines. –  Tim Aug 28 '11 at 11:45

Can you check if this helps? How to Configure WPA support in Windows XP

I'm also having the same problem actually, one of our older Windows machine was not able to connect to our router when we switched from WEP to WPA-TKIP. I can't seem to find the option to use WPA from the Network Connection properties. I only see Open/Shared for Network Authentication and WEP/Disabled for Data Encryption.

Would you guys know if this is a driver issue? Or a service pack problem? I have SP 3 installed in the machine which cannot connect using WPA.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.