Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using multiple browsers successfully for years, but now I seem to have run in to a problem. When I run firefox or IE, they appear to start up, but the mouse pointer just permanently turns into an eggtimer, and I can do nothing else with them. Task manager shows them as "not responding". I then have to use task manager to "end task". I tried re-installing firefox, but that made no difference. Google chrome works fine. Any ideas what could be happening?

EDIT: Firefox has just spontaneously started working... I have no idea why.

EDIT: Firefox has just spontaneously started failing again... I have no idea why.

EDIT: Firefox has just spontaneously started working... I have no idea why.

EDIT: After a couple of reboots and all three browsers are now working.

share|improve this question
    
Please try running Firefox with a new profile (firefox.exe -P will take you to the profile manager). Another possible source is that your computer may be infected with malware. –  Bobby Apr 6 '10 at 9:26
    
@Bobby: I tried your suggestion, but it locked up straight away, i.e. it ran, I saw the firefox window frame, but then I had the dreaded eggtimer and I had to do a manual "end task". –  Mick Apr 6 '10 at 9:31
1  
Any recent changes to your system? –  random Apr 6 '10 at 9:35
    
@random: no. (superuser has a minimum comment length so here are some extra words... blah blah). –  Mick Apr 6 '10 at 9:40
    
Uninstall all Browsers, then install Firefox and see whether or not it works fine. –  Mohammad Apr 6 '10 at 9:40

5 Answers 5

Try running IE or Firefox with no Add-Ons.
For IE, there should be an option for this under Start > Programs > Accessories > System Tools > Internet Explorer (no-Addons)
For Firefox, try Start > All Programs > Mozilla Firefox > Mozilla Firefox (Safe Mode) and then tick the Disable all Add-ons option.

share|improve this answer
    
No-addons ie still failed in teh same old way. –  Mick Apr 6 '10 at 14:38
    
Did firefox respond? –  Jeff Martin Apr 6 '10 at 23:07
    
@jeff martin: firefox is mysteriously working again. –  Mick Apr 7 '10 at 10:49

If System Restore isn't disabled (for performance reasons), perhaps you could restore to a point before the trouble started?

share|improve this answer

If your system isn't infected with something, it may be a bad profile.

Can you create a new user on your system, then log in with that user? What happens?

share|improve this answer

I'm going to echo what chris is saying here, but I think you should just try to do it on your own account without creating another entire profile.

Either find out where the Firefox profile is kept and delete all of those manually or run revo-uninstaller which will scan the registry and the directories for settings/files that were left over.

share|improve this answer

Uninstalling Firefox doesn't remove your profile directory. Hence, if there's something broken in the profile directory, reinstalling Firefox won't have any effect.

I understand that even with a new Firefox profile, it hangs? This indicates that the problem isn't Firefox itself or your profile, which is very strange indeed. I would otherwise suggest Firefox Safe Mode, but that won't work here.

Perhaps your antivirus software is locking a file? You might want to use a profiling application such as Process Monitor to determine what Firefox hangs on specifically. Start monitoring your system with Process Monitor, and immediately start Firefox. After a few seconds of hanging, stop monitoring, and set up a view filter to only display Firefox's PID.

The only other thing that comes to mind is malware since both browsers have stopped working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.