Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Motorola phone, with a MicroSD slot, which my Ubuntu machine does not recognize as a USB drive.

It does know there is something there since

  • It automatically charges my phone whenever I connect it.
  • using the command lsusb shows it as "Motorola PCS"

Is there a way to tell Ubuntu/Linux that the connected hardware is a disk drive?

share|improve this question

You probably have the phone in "Data Connection" or "USB Printing" mode instead of "Memory Card" mode. Go to USB Settings (in Settings | Connection on my phone) and change it.

share|improve this answer
    
It has Settings > Connection > USB Setting, in which you can choose between "USB Drive" and "Modem/COM". Neither works in my Ubuntu box. – lamcro Apr 6 '10 at 15:10

Is there an option on the phone to turn on USB Drive mode? My phone(Motorola Rival) will not appear on my windows machine until I turn this setting on.

I found it under Menu -> Settings & Tools -> USB Mode.

share|improve this answer
    
Yes, but no luck. It does work on Windows with no problems. – lamcro Apr 6 '10 at 15:06

You first mount it on Windows. Do not Unplug the Phone and Then reboot the PC to Linux (I am Assuming you have dual Boot Windows/Linux) Now when Linux Starts Open the terminal type the following Commands one by one and post all the outputs here. sudo fdisk -l, lsusb, dmesg If some command requires root permission run that with sudo

share|improve this answer
    
Sorry, I've been Windows free (at home) for a while. But I will try and run those commands. – lamcro May 25 '10 at 5:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .