Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Question: How do I have my netbook detect and install hardware?

Info: I have an Acer Aspire One, it came with windows XP and I loaded it with Win7. I decided I wanted to change to Ubuntu so I tried Ubuntu netbook remix, which failed horribly, and so after attempting 3 or so other OS's I ended with Ubuntu Desktop 9.10. Which worked fine for a while, but there were some minor issues so I asked a question about it here and decided to change my OS again.

This last weekend I tried mandriva like that guy in my other question suggested, no success. when I had though my netbook lost the ability to use it's touch pad, I didn't think much of it, just thought it must be a driver or something. But When Mandriva failed, and I also while I was at it tried Damn small linux and Debian, which both failed to, I decided to switch back to Ubuntu Desktop(some where in here my keyboard stopped working for one attempt to). But first I gave the netbook remix one more try. it worked this time, with the exception of it didn't have any networking. I thought it was a driver issue again and finished the weekend with ubuntu desktop 9.10 again.

But now things get really crazy. it doesn't know it has a wireless card or an ethernet card. It doesn't know my phone is connected trying to provide wireless broadband either. I'm clueless on what could be the problem. And with only a minimal amount of experience with Ubuntu can't navigate the entire interface with only my keyboard(it doesn't detect a USB mouse when I plug it in, it had when I installed it. in fact the network interfaces were working just fine when I live boot ubuntu to installed it). Even so, I don't know where to go or what to do to make it recognize it's hardware. I'm in a dire situation, any help is welcome.

Update: I ran lshw and it listed Atheros AR8132 gigabit ethernet and Ar5001 Wireless network adapter. I ran lsusb and it listed Samsung (I have an omnia). So it knows they are all there, but it doesn't accept info from any of them...

share|improve this question
up vote 2 down vote accepted

Have you installed these many, many different OS OVER the existing OS? Or did you first format the whole disk, so nothing can stand in the way of the new installation. Maybe every installed system found some driverfiles and tried them... result: fail to iniciate some hardware.

share|improve this answer
I may have installed over. I partitioned off the drive into 3 peices: OS, Swap, Media. Between the installations only OS was wiped. Media should only house my music, pictures, class notes etc. could it be that these to partitions are giving me the problems? P.S. I never had the installation process import information from the prior OS. – Narcolapser Apr 6 '10 at 13:41
Sure it is possible ^^ I quess I can quote one of my favourite heros here: "Never trust to general impressions, my boy, but concentrate yourself upon details." (Sherlock Holmes) Try to install ubuntu again, but create a completely new partition table and format the disk. – Diskilla Apr 6 '10 at 13:49
kk. I'll get back to you hopefully later today. Thank you kindly. – Narcolapser Apr 6 '10 at 13:50
as strange as it is, that was it. I created a new partition table and installed Ubuntu and everything is working the same as it was previously. with the exception of my touch pad, but that went out before I changed the OS. I think I'm going to give Acer a Call about that one. But anyway, Thanks! all is well. ~N – Narcolapser Apr 7 '10 at 5:05

I had the same problem with my Acer Aspire D250 because the wifi drivers were proprietary and i needed internet access to actually download and install them. I just plugged it up to lan and it worked fine. I dont exactly think this is your problem but it might work. Is it a D250 aspire?

share|improve this answer
Quote: it doesn't know it has a wireless card or an Ethernet card. i.e. I don't have any lan. – Narcolapser Apr 7 '10 at 4:27
whoops. I missed that Sorry – bizarrechaos Apr 7 '10 at 4:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .