Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am getting this message:

internal compiler error: Segmentation fault Please submit a full bug report, with preprocessed source if appropriate. See <file:///usr/share/doc/gcc-4.4/README.Bugs> for instructions.

for every compilation that takes longer (ie: linux kernel, kde sources etc.)

I've tried other OS (at that moment I was on Fedora 12, now on Debian; was a Suse also) and it didn't work. I've tried replacing my hard disk, since it needed an upgrade either ways - that didn't work either. I assumed that it's the RAM fault - tested them with memtest and it says they are fine.

Does anyone know what else I can do in order to figure out where the problem is?

share|improve this question
    
it's not a hardware error, and I don't have the same problem, so it must be a problem between computer and chair :P do you use any abnormal compiler flags? Is it 32 or 64 bit? Can you do other computationally intense things? (memtest doesn't really test your processor) can you try getting a backtrace from gcc? –  Earlz Apr 6 '10 at 17:54
    
there's no weird compiler flags, even if I use the default settings, I get the same behaviour. Err, how do you get a backtrace from gcc, besides what I've already posted? ;-) –  hyperboreean Apr 6 '10 at 18:09
    
attach gdb to gcc and then run then it'll crash eventually and you'll get told at what address and stuff, then just type backtrace and it should tell you where it crashed. –  Earlz Apr 6 '10 at 18:21
    
here's one: pastebin.com/hjVFcrtN ... though I am pretty sure the gcc guys will tell me that this is a hardware issue .. been there –  hyperboreean Apr 6 '10 at 22:18

2 Answers 2

up vote 3 down vote accepted

the last time i had this error: ram was defect.

share|improve this answer
    
This was the problem, I just acquired a new memory dimm and the problem is gone. Thanks! –  hyperboreean Apr 7 '10 at 18:35

Try checking out your processor's heat levels - it could be that things are overheating leading to errors while the CPU is under heavy load.

share|improve this answer
    
Yea, memtest usually heats up the CPU pretty well though.. course, no computations really in memtest. –  Earlz Apr 6 '10 at 18:22
    
Seems to be comfortable at around 45-46 degrees Celsius, which seems okish, given the fact that it is an Athlon XP 64 –  hyperboreean Apr 6 '10 at 22:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.