Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On all of my home computers, I can enter my documents into the Start > Run prompt and the My Documents folder of the current profile will open up. What's more, I can continue typing subfolders, files, etc. and auto-complete works and it's smart and enjoyable. I can't check at the moment, but I'm almost positive entries like My Pictures and My Music also go to their correct folders.

On my work computers, if I enter my documents into the Start > Run prompt, I get the following error:

"Windows cannot find 'my'. Make sure you typed the name correctly, and then try again. To search for a file, click the Start Button, and then click Search."

Entering "my documents" (with the quotes) into the field produces a similar error, although it of course changes to reflect that 'my documents' can't be found.

I can sort of circumvent this by creating a shortcut in my PATH named 'my' that points to My Documents folder, but this doesn't solve the auto-complete option (and it's otherwise imperfect, of course, because "my pictures" or "my music" all direct to the same place.

A google search doesn't provide much help on this, although it does identify a poster in 2007 with this same question at another board: http://www.msfn.org/board/lofiversion/index.php/t124813.html (Login required, but Google cache available here: http://preview.tinyurl.com/ygxhwwl)

Is this just a limitation of the networks belonging to a domain, or is there some way I can get this functionality back? My documents folder does live in the standard place (C:\Documents and Settings{username}\My Documents), and not on a network drive or anything.

It's probably worth adding that the computers are part of some freakish Novell domain thing, too. I'm not in IT here so I'm not too up on the details.

Thanks for any help/suggestions!

share|improve this question
    
@Clayton, I don't think it's Novell related because I experience the same thing on my office XP computer that's in a domain, and we don't use Novell, and I've verified that it works at home on my workgroup computer. –  Marcus Adams Apr 6 '10 at 21:49
    
possibly folder redirection? –  tonyr roth Apr 6 '10 at 22:10
    
@Marcus - that's good to know, but I wasn't positive. –  Clayton Hughes Apr 7 '10 at 16:25
add comment

2 Answers

up vote 2 down vote accepted

I've noticed this also. On my home computer I can type my documents in the Run box and it opens the My Documents folder. But on my work computer it doesn't work.

I haven't found what setting turns this off or on, but I played around with it now and noticed the following pattern: You can type the name of any file or folder in your Documents and Settings\username folder without quotation marks, even if it has internal spaces, and it will open correctly.

This suggests the Documents and Settings\username folder may be a default location used if the command entered in the Run box isn't found, and it works even without quotation marks. This clue may help us discover the true setting or reason why this works.

Further tests

I compared the environment variables on my home and work computers and noticed the following difference.

At home, HOMEDRIVE and HOMEPATH together point to C:\Documents and Settings\username

At work, HOMEDRIVE and HOMEPATH together point to X:\ (a networked drive letter). My work computer also has a HOMESHARE variable that indicates the share name of the networked drive letter.

At work, I was able to enter the the names of files or folders in my X:\ folder in the Run box, without quotation marks, even if they had spaces in them, and they opened correctly.

Answer

After some testing, it looks like the Run box searches for matches without requiring quotation marks in the home folder first, then it moves on to searching for matches in the PATH and requiring quotation marks if the name contains spaces.

The correct way to change the home folder is to use the Computer Management tool to modify the properties of the user in question. The environment variables are automatically set by Windows based on the user properties and changing the variables yourself may cause unpredictable results. (That last page is for Windows 2000, but I guess the same advice would apply to Windows XP.)

Workaround

To restore the ability to enter my documents into the Run box, you can put a shortcut in your home folder named My Documents that points to the correct My Documents folder. (To quickly open your home folder, enter . in the Run box.) However, the shortcut doesn't work with additional subfolders on the end of it.

share|improve this answer
    
Good point, Bavi. Maybe as nicorellius alluded to above, %USERPROFILE% (which generally points to C:\Documents and Settings\username) is in the PATH variable. That could cause this... –  Clayton Hughes Apr 7 '10 at 16:24
    
Clayton Hughes: I think it's something more special than the PATH. The Run box recognizes files or folders in the home directory that have spaces in their name without requiring you to put them in quotation marks. PATH locations don't work like this. Also, my home directory isn't in my PATH and the Run box still searches it for matches. –  Bavi_H Apr 7 '10 at 23:54
    
Re the shortcut workaround: At home, my home folder is on my computer and I could enter my documents in the Run box to start the shortcut. But at work, my home folder is on a shared network location, and I had to enter my documents.lnk in the Run box to start the shortcut. –  Bavi_H Apr 8 '10 at 22:29
    
Thanks for the excellent research, Bavi! It appears this might not be the case, though, when your home folder is set to C:\ –  Clayton Hughes Apr 14 '10 at 16:57
add comment

Are you actually putting quotes around "my documents"? You should be, otherwise it tries to run "my" with "documents" as a parameter, which obviously is not right.

share|improve this answer
    
It works without quotes on the home pc. It still fails with quotes on the others (the message changes to reflect that 'my documents' can't be found). I'll update the question with this info. –  Clayton Hughes Apr 6 '10 at 19:10
    
I can type My Documents into Start > Run and it opens the appropriate folder. Have these folders been renamed? I have seen weird things happen after renaming user folders under Docs and Settings. Also, you may want to check you PATH variables. –  nicorellius Apr 6 '10 at 22:00
    
As far as I know, the folders haven't been renamed. Do you suggest adding %USERPROFILE% to my path? I'll have to check, but I'm almost certain it's not in the PATH for the working machine. –  Clayton Hughes Apr 7 '10 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.