Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using CentOS. I cannot connect remotely and I believe it is related to fact I can only connect locally if DISPLAY is set to :0.0. Something is misconfigured but I can't figure out what.

>xhost +

    access control disabled, clients can connect from any host

>emacs -d :0.0

    #works

>emacs -d 127.0.0.1:0.0 

    Cannot connect to X server 127.0.0.1:0.0.

>emacs -d localhost:0.0

    emacs: Cannot connect to X server localhost:0.0.
share|improve this question
up vote 0 down vote accepted

This is because Xserver is refusing TCP connections

run gdmsetup as root and uncheck "Deny TCP connections to Xserver"

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .