Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a linux machine with a samba-share. Other windows machines can access that samba-share no problem. Now I have a new MacBook running Snow Leopard and I have no clue on how to access it. In finder it shows the linux-machine, but I have no idea how to access it. In some blog it said that this:

`smbclient -U <username> -L <hostname>`

can be used to list samba-shares. When I do it, I get

`session setup failed: NT_STATUS_LOGON_FAILURE`

I am at a loss here. Any help on how to approach that problem would be appreciated. Can you provide some hints or point me to some good howto?

EDIT Ok, I am stupid. It was configuration error on the samba-server, I mixed up the passwords.

share|improve this question
2  
by all means post your own answer below, to explain the problem and any steps you took to solve it. you can accept it after a couple of days. it may seem like a silly mistake but this info may help someone else in the future. thanks! –  quack quixote Apr 19 '10 at 12:30

3 Answers 3

You don't need to use the command line. You can just browse to in the Finder (Go => Connect to Server...). If it doesn't show up in the browser for some reason then you can also type a URL of the form:

smb://user@machine/share

share|improve this answer

When in finder hit command+k and type smb://servername/share into the box.

share|improve this answer
    
I tried this, the problem is, it doesn't recognize the password. –  Björn Pollex Apr 6 '10 at 20:14
up vote 0 down vote accepted

As suggested by @quack quixote I post my own answer here. The problem was that I simply forgot that you can have a Samba manages its users independently from the system, accounts with the same name can have different passwords. I set the passwords to be the same, and now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.