Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Well, I'm trying to get a database schema thing working, first I tried just doing it in Linux where I'm more comfortable, but ODBC seems to be a hack there and I couldn't get it to work. So I figured it shouldn't be too hard in Windows..

Ok, so I created a SQL Server Client Alias so that I can simply same windowsserver to refer to my SQL server.

Then, I went to the ODBC configuration in Control Panel. I clicked Add in the User DSN section. I chose Native SQL Server (10), and then clicked next. Then I typed a short name and a description and gave the servername as windowsserver/SQLEXPRESS

Then, I click next, give it my user name and password and click next. Then, after like 2 minutes it says "Login Timeout Expired"

What can be wrong here? I know the server is configured cause I have SQL Server Management Studio opened up with that server in it.

I'm also just trying to connect over regular TCP/IP and my firewall is disabled.

share|improve this question
add comment

2 Answers 2

You say you are trying to connect over TCP/IP, however using the server windowsserver/SQLEXPRESS will use the default Named Pipe transport. You have two options:

  1. Really use TCP/IP. Specify the server in the form of \\windowsserver\SQLEXPRESS which should tell the driver to use the Network Transport.

  2. Enable the Named Pipe transport. You can do this by going to Start->Programs->MS SQL Server 2008->Configuration Tools->SQL Server Configuration Manager. Then under the SQL Native Client Configuration option make sure the Named Pipes is enabled.

share|improve this answer
    
Just tried your first solution, didn't work. Still gives the same login timeout. For solution #2, I don't think Named Pipes are enabled at the server level(for remote access). Named pipes are enabled though on my client already. –  Earlz Apr 6 '10 at 21:05
    
@heavy Actually, I get an error that the connection string is invalid when using that.. –  Earlz Apr 6 '10 at 21:09
add comment
up vote 0 down vote accepted

Turns out that sometime between me testing the connection and setting up the ODBC connection, the server stopped responding. After restarting the server it all worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.