Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I get the message

No fonts match '9x15'

when trying to run emacs and a linux box. I messed something up a while back, but I do not know how to fix this issue. Any ideas?

share|improve this question
    
I am having a similar problem on Emacs 21.4.1 on CentOS 5.5. I tried to use Inconsolata-12 (silly me) and now emacs won't start without the -fn flag. I can't find where Inconsolata-12 is specified in any of my configuration files, like .emacs. Help? –  noahz May 9 '12 at 14:00
    
I can't remember if I resolved this or just kept using a work around. I no longer use that server. –  bbarnhart May 9 '12 at 14:46
add comment

2 Answers

Have you installed Xming-fonts package and read Xming fonts page?

With X11, the fonts are from the server, in your case Xming running on a PC, not the system executing the client application (emacs running on the Linux is a X client).

This doesn't appear to be a Linux or emacs issue.

share|improve this answer
add comment

Does emacs still run? if so run M-x customize-group basic-faces - change the settings for default face, and save for future sessions.

If not, run "emacs -q" (this suppresses loading your init file) and then customize your default face.

share|improve this answer
    
emacs does not run after returning the 'No font match' message. emacs -q also returns 'No font match'. The problem is with the X window and I'm using Xming. If I start a new putty session without setting the display emacs works fine. –  bbarnhart Apr 7 '10 at 20:40
    
Please Add Xming note to original question, to improve others answers. –  mctylr Apr 7 '10 at 20:44
    
use the -fn flag to select a font that exists: "emacs -fn fixed" should work, for example. –  Justin Smith Apr 7 '10 at 22:35
    
also, you can set your default font from "emacs -nw" (which is the equivalent of running emacs without the display set). –  Justin Smith Apr 7 '10 at 22:35
    
also, as mctylr mentions - if the problem is a missing font, that is a problem with the server on which the app is displayed (in your case Xming under Windows) not the Linux client. –  Justin Smith Apr 8 '10 at 1:24
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.