Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to automatically mount a windows share in a Fedora 12 instance (FC12).

When I manually mount things work:

mount -t cifs //nas01/servers -o username=guest,password=myPassword /mnt/nas01/servers

If I update /etc/fstab with the following:

//nas01/servers /mnt/nas01/servers cifs username=guest,password=myPassword 0 0

Nothing happens after reboot.

The thing that has me baffled is after a reboot if I run:

mount -a

The share is mounted.

Any ideas on this?

Thank you,

Martin

share|improve this question

3 Answers 3

up vote 1 down vote accepted

It could be that when your fstab is processed all required prerequisites aren't in place to mount the network share.

You can try adding the mount command to your rc.local startup script.

share|improve this answer

From man 8 mount:

FILESYSTEM INDEPENDENT MOUNT OPTIONS
_netdev
The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).

share|improve this answer

Fedora has a script netfs that parses fstab a second time during boot once the network is up to mount shares:

chkconfig netfs on

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.