Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have setup IIS on my xp machine and have setup a default homepage (that comes with the IIS installed). It is a help page I think.

when I access the page with http : // localhost it works fine (IE/Chrome or FF) but when I access it using http://hostname it prompts for a loging/password and works when I enter my domain id and password on the intranet.

I have ensured that "anonymous access" is enabled in the properties window of the default site and "websites" node.

I searched stack overflow for similar queries but some indicate I need to change the IE/FF settings to allow "integrated security" etc and some suggest to look at the "log file".

I don't want to change the IE setting and there is nothing unusual in the log file of the IIS Server.

Can anybody help me figure out why this is happening?

thank you sb

share|improve this question

2 Answers 2

You need to add http://<hostname> in Internet Explorer, "Security for local intranet".

Steps:- Go to IE --> Tools --> Internet Options --> Security --> Local intranet --> Sites and add http://<hostname> where <hostname> is the name of the computer that is hosting IIS.

share|improve this answer
  1. Go to IIS Manager

  2. Go to the Properties of the website

  3. Go to "Directory setting" and then Edit

  4. Check "Integrated Windows Authentication"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.