Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Dreamweaver CS4 auto-detects the language for non unicode programs in windows, in my case it is russian, and conviniently sets the default encoding to be western european instead of the much preferred utf-8, it also changes several bits of text in DW into russian.

how do i disable this detection and maintain Dreamweaver in full english? (without having to change the language for non-unicode programs in windows)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

As detailed here, you should be able to set the default encoding to UTF-8 (preferably without BOM) in the Preferences. I don't think this is affected by the system codepage.

The system-codepage-sniffing to change UI language is sad. I'm seen this commonly in poorly-written Japanese programs, but for DW to be doing that too is disappointing. Applications that do this need to be taken outside and shot. To get around it, you can use apploc to change the codepage a particular application sees when it runs.

share|improve this answer
    
I have set it to UTF-8 in the preferences, and it stays so too, but DW STILL converts the files to western european because of the system-codepage-sniffing, if i remove the russian from the windows settings all is fine. "Applications that do this need to be taken outside and shot." I absolutely wholeheartedly agree. Thanks for the apploc feature :) –  Timo Huovinen Apr 10 '10 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.