Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am not a user of Linux, but I am encountering some permissions problems with it that I hope someone can shed some light on.

Bit of background: A colleague of mine has a Linux box (running Debian I believe) with an SVN repository on it. The repository directory and files 'owner' is my colleauge. We are both members of a group called 'users'. He manages several projects both Linux and Windows apps, while I have one Windows app. For the Windows apps, we both use TortoiseSVN via an SSH link to commit/update.

Performing the command 'ls -l' shows the repository files and folders on the Linux box to have the following permissions:

-rwxrwx--- john users

However, when my colleauge commits to the repository, the permissions change to:

-rwxrwx--- john john

This then means I get 'Permission denied' when trying to access the repository myself as it appears that the group permissions have been overwritten with only 'owner' permissions.

To fix this, a 'chown -R' command is applied to the files/folders to set the permissions back to owner/group, but each time he writes to the repository, the issue repeats.

I'm not sure if this is solely an SVN problem, or a more fundamental owner/group issue.

Anyone any clue on how to stop this happening, or where to go and look? I'm trying to help out my colleague who is having some trouble resolving this issue.

Apologies for the vague info, I hope I have conveyed the problem clear enough. Like I say, I am not a Linux user, I have only put down what I have managed to pick up from looking over his shoulder.

Thanks for any pointers I can pass on!

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I would speculate that john's primary group is john, and that SVN is deleting and re-creating the file when he commits, rather than overwriting it in place.

If you want all of the files to have the same group ownership, you could try setting the setgid bit on the repository directory (making sure the directory is owned by the users group).

share|improve this answer
    
Thanks for the quick reply. After a quick Google about primary groups, this looks like a possibility. Found this article, is this what you mean?: articles.techrepublic.com.com/5100-22_11-5349294.html –  Andy Apr 9 '10 at 17:54
    
Yes, that's a good overview of primary groups vs. secondary groups. I was thinking that setgid bit would be the easiest way to go, but you could go the route of changing your users' primary group, or telling them to use newgrp, if you prefer that approach. –  coneslayer Apr 9 '10 at 18:07
    
Being a Windows XP drone, I have no idea which is the easiest/best route to take :) But it's good info which I will pass on, thanks. –  Andy Apr 9 '10 at 18:11
    
It has been fixed by performing a 'usermod' command to set the group. Don't know much more about it than that, but your answer got us on the right track, so I'll mark it as accepted, thanks. –  Andy Apr 12 '10 at 19:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.