Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought an AirPort Express to enable music in a different part of a friend's house using the AirTunes feature. Unfortunately, iTunes or the AirPort Utility don't reliably discover the existence of the device.

If I use the Configure Other... function within the AirPort Utility and enter the AirPort Express' IP address and password, then I can reliably get access in a daughter window to configure it. Clicking Update in the daughter window seems to nudge the underlying AirPort Utility into finding and displaying the AirPort Express, which it doesn't do on its own even after clicking the Rescan button. iTunes then also seems to cotton on to this discovery and present the AiportExpress as an AirTunes option at the bottom right of iTunes. Things then work as we'd like them to.

If I close down the AirPort Utility, then iTunes loses the AirPort Express AirTunes speaker, often giving "An unkown error (-15006) occurred while connecting to the remote speaker".

Question Of course, starting the Airport Utility, forcing it to recognise the Airport Express and then starting iTunes, isn't the ease of use we were after. How do I get AirTunes working reliably? What other things might I try?

Background info:

  • iTunes is running on Windows XP.
  • The AirPort Express is running in wireless client mode (i.e. is connecting to an unsecured wireless network in the house with nothing connected to its ethernet port). It responds to Mulitcast ping requests.
  • The network router is a Swisscom Motorola 3347NWG.

I have already tried (with Spiff's valuable help - apologies that I don't yet have enough rep to upvote his answer):

  • Disabling the Windows XP firewall
  • Updating the AirPort Express firmware 7.4.2, the AirPort Utility 5.5.1 and the router firmware 7.8.5r1
  • Ensuring Wireless Privacy and similar potetnially problematic router settings are off
  • (Re-)installing Bonjour print service, iTunes and the AirPort Utility (to maximise Bonjour's chances of working)

It currently seems that the problem is that Bonjour doesn't work across from the router's wireless LAN to it's wired LAN. If the AirPort express is connected wired, then it works.

I'm also suspicious of WinXP's Firewall. However iTunes (iTunes.exe), Airport (APAgent.exe), AirPort Utility (APUtility.exe), Bonjour (UDP 5353) and the Bonjour Service (mDNSResponder.exe) are all registered exceptions. Also, the symptoms are the same when the WinXP Firewall is switched off.

Mulitcast ping on 224.0.0.1, per Spiff's question, does get responses from the Airport Express as long as the WinXP firewall is turned off (which is as it should be I suspect - legitimate Bonjour requests should benefit from the Firewall exceptions above).

My friend's PC doesn't have a wireless card and so I can't try Spiff's other suggestion.

share|improve this question
    
I found this post with a resolution that seems to work - for anyone but me :-( But you might be anyone so try it out: discussions.apple.com/thread.jspa?messageID=11561278 –  user38656 May 29 '10 at 19:03

4 Answers 4

up vote 1 down vote accepted

Your symptoms suggest multicast or Bonjour aren't working right on that network. Here are some things to try, which will be useful data points in figuring out the underlying problem:

  • Verify that your Express is running firmware 7.4.2, which is the latest. If not, upgrade it. No use fighting a bug that may already have been fixed.

  • From the XP box, ping the all-hosts multicast address 224.0.0.1. You should see duplicate ping responses, one from each device on your network. Note whether you reliably see ping responses from the IP address of your AirPort Express. If you don't see ping responses from the Express for every ping request, it means multicasts aren't getting from your Motorola box to your AirPort Express reliably. It could be that your Motorola box doesn't handle multicasts well, or it could be that your current "multicast rate" setting on your Motorola box is too high, and the Express can't receive them reliably at that rate in that location.

  • Is the iTunes XP box wireless? Do you have any other computers on the network, wired or wireless? If so, then try pinging 224.0.0.1 from one of the other computers, and see if the iTunes XP box responds reliably. It may be that multicasts aren't getting to the iTunes XP box reliably, which could cause Bonjour failures.

  • Temporarily configure the AirPort Express as a standalone AP, publishing a different network name (no security), with NAT and DHCP ("Share a single IP address") enabled. Join your XP box wirelessly to the AirPort Express. See if everything works correctly that way.

  • (Re-)Install the latest version of iTunes. Hopefully this will re-install the Bonjour service (mDNSResponder) for Windows. Having to keep the AirPort Utility open may suggest that Bonjour is only working properly when the AirPort Utility is keeping it open. Bonjour should work just fine even when iTunes is the only client of it. It makes me think something's wrong with your Bonjour installation on your XP box.

share|improve this answer
    
I would upvote this answer, but I don't yet have enough rep. Not yet at the answer but am much closer and have factored pertinent additional detail into my question as a result. –  andybjackson Apr 11 '10 at 0:17

Here's a tip for some of you that have issues with Airport Expresses dropping off Airport Utility/Airplay: After months of my ethernet-connected Airport Expresses dropping off Airplay in iTunes, and only appearing in about 2 minutes after a power off/on in Airport Utility/iTunes (Windows), I finally got it all working.

It turned out to be that the home router (Netgear WNDR3700) was blocking Bonjour multicasts over its switched ethernet ports and WiFi (although set up as no to, according to Netgear support, no GMPL spoofing etc). Connecting the ethernet ports to a bona fide switch (LinkSys LGS124) instead and using the Netgear router as a WiFi Access Point only, everything started to work and has been rock solid ever since! Never a drop, always appearing in iTunes (Windows) and iOS devices and I now have a super multiroom audio system with four Airport Express units. Now I am just waiting for Apple's rumored 24-bit/96 KHz update for Highdef audio ;-).

It did 'work' before when all was wirelessly connected, but then I had drop out issues due to WiFi interference and low signal strength in some rooms (big 19th century house with brick walls). This is why I installed Cat6 throughout and shifted to GigE in the first place.

I have seen many posts about disappearing Airport Express from Airplay and that Airport Utility cannot find the units - this post may provide a hint. Check out your router! If it's a run of the mill home router and not by Apple, chances are that it blocks the Bonjour multicasts by default - and you may not be able to configure it not to. I also tried with an ASUS RT-A66U with the same results as the WNDR3700.

share|improve this answer

You may be glad to know that on return to the UK, the AirPort Express and its AirTunes function works as it should on my UK home network in the exact configuration deployed at our friends' Swiss house, but may be sad that it makes it harder for me to diagnose and return it to them with a fix.

There are three possible reasons why it doesn't work en Suisse:

  1. Man masquerading as engineer (MMAE, aka me) is too thick.
  2. Something specific about the WinXP wired PC's config is preventing it from working.
  3. Something specific about their Swisscom Motorola router is preventing it from working, in particular in the interaction between devices connected wirelessly and wired since it appeared to work when connected by wire.

The first of these is beyond MMAE's ability to diagnose.

I'd like to exclude 2. by seeing how another PC armed with iTunes (but not with any corporate firewall software or other potential complication) behaves when connected wirelessly and wired, whilst the AirPort Express is suitably configured and connected.

If said other PC doesn't function as intended and confirming suspicions that 3. is the cause, appropriate next steps might include:

  • Wire the AirPort Express (tricky given distance and walls).
  • Replace/augment the Swisscom modem router with wireless access functionality that does enable the AirPort Express to do its job.

If other PC does function as intended, then that would be a good reason to accelerate a Windows 7 upgrade on their PC, as solving this problem would be a likely beneficial side-effect.

Whilst I get this done, I'll be researching Bonjour in case that can reveal what the router and/or PC problem(s) might be. Guidance and comments would be much appreciated.

share|improve this answer
    
Just spotted superuser.com/questions/12066/…. –  andybjackson Apr 14 '10 at 7:45
    
Also see page 211-214 (dealing with CLI configuration of IGMP) of the Motorola's manual as published by Qwest qwest.com/internethelp/modems/motorola-3347/pdf/… together with en.wikipedia.org/wiki/IGMP_snooping. –  andybjackson Apr 14 '10 at 9:44

I had a similar problem. It seems that the Swisscom router does not support the multicast messages that Bonjour depends upon to make devices (time capsule, airport express) appear visible on the network. I think that the same applies to apple TV and other apple devices - maybe including airplay enabled ones.

The solution I came up with was to add a dirt cheap (30CHF) dlink wireless router (DIR-600) on one of the LAN ports of the Swisscom router. You do need to make sure that you set up the DLink up correctly. Try this:

  1. Out of the box connect the D-Link directly to your computer using an ethernet cable. Don't connect the D-Link to your Swisscom router yet. Make sure that you are not connected to another network (for example turn off wireless) The default IP range is 192.168.0.100- with the router at 192.168.0.1. Point your browser at 192.168.0.1 (or whatever your router's default address is). Login into the router.
  2. First you need to deal with the internet connection options. This relates to the WAN port that you will eventually connect to the Swisscom. Set the router to Static IP and set the router address to one that is in the same range as the Swisscom router. In my case the Swisscom router was in the 192.168.1.0 range and I set my static IP address to 192.168.1.63. Set the subnet mask to 255.255.255.0 and set the default router address to that of your Swisscom (my case 192.168.1.1) I also set the DNS to the same address and this seemed to work - I guess you could get the DNS address of the ISP and put it in here if you want. Save the changes.
  3. Next you need to need to set the Network settings. These are for the downstream side of the router for the connections to your own home network computers and devices. I will tell you what I did which works. In the router settings set your router address to a different range to your Swisscom. In my case I used 192.168.2.1. Set the subnet address to 255.255.255.0. Make sure that DHCP is enabled. When you save the changes you will have to reconnect to the router with the new address - it should warn you.
  4. Re-connect to the router with the new router address and then set up your wireless network. Give it a distinctive SSID that is different from the one that your Swisscom is giving. Set up your WPA security and set the password and save the changes.
  5. Unplug the Ethernet cable and then connect the WAN (internet port) on the router to one of the downstream ethernet ports on your Swisscom box.
  6. You will now need to connect each of your apple bonjour devices to either the wired or wireless ports of your newly created router network. With Airport expresses I find the easiest way is to either connect an ethernet cable directly from your computer and then run the airport utility or connect an ethernet from the express to the D-link router. Then run the Airport utility and change the settings so that the express joins your newly created wireless network. Once you have updated the settings you can then unhook the ethernet cable. Make sure that all your bonjour devices are connected to your the new network.
  7. If you have a Swisscom IP TV set top box it's best to leave it connected directly to the Swisscom router. It may work connected to the second router, but if there is no need to change it why bother. Bear in mind that any devices that you connect either to the wireless or wired network of the Swisscom router will not be able to "see" the devices connected to the D-link unless you play around with detailed set up on the D-Link.

One of the good things about this set up is that you do not need to mess with the Swisscom router at all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.