Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to make a DVD and the final DVD jerks when played on standalone DVD players. It seems to play fine on PCs.

I think the problem may be to do with interlacing settings when rendering the final output, but I'll outline the whole editing process I have followed in case I've made a mistake somewhere else.

Most of the footage comes from a sony handy cam (one of those mini DVD ones) so isn't great quality. It was set to "high quality" (haha) and 16:9 aspect ratio when it was recorded.

I copy the files directly from the mini DVDs onto the hard drive and import them into Cinelerra. In Cinelerra I set the format to 25fps, 720x576, RGBA-8bit, 16:9, interlaced bottom fields first.

When I've finished the editing, I add a Fields to frames effect (set to bottom first) to each video track.

I render to audio and video separately:
Audio: AC3, 128kbps
Video: YUV4MPEG steam,

video pipe settings:

ffmpeg -f yuv4mpegpipe -i - -y -target dvd -flags +ilme+ildct mpeg2video %

Cinelerra often crashes during the rendering, so I set it to generate a new video file at each label, and combine them using cat when I've got a sucesful render of each one. Once I've combined them, I use mencoder to re-index them:

mencoder -forceidx -oac copy -ovc copy merged.m2v -o mergedReIndexed.m2v

I combine the audio and video files using ffmpeg:

ffmpeg -i AudioFile.ac3 -i VideoFile.m2v -target dvd -flags +ilme+ildct FinalMovie.mpg

Then I build the menus with spumux and I create the DVD file system with dvdauthor, and finally I write it do a dvd-r like this:

nice -n -20 growisofs -dvd-compat -speed=2 -Z /dev/dvd -dvd-video -V VIDEO ./ && eject /dev/dvd

Originally, when I did it the DVD flickered badly, so as suggested in a guide I added the fields to frames effect in cinelerra. Now it doesn't "flicker", but has become "jerky" when there is lots of motion, particularly when the camera is moving, so the whole background moves.

This is what I've tried so far:

  • Removed "mpeg2video" from cinelerra video render pipe.
  • Removed +ilme from render pipe.
  • Removed +ildct from render pipe.
  • Removed +ilme from render audio/video rejoin command.
  • Removed +ildct from render audio/video rejoin command.
  • Added -alt to render pipe.
  • Added -alt to render audio/video rejoin command.
  • Tried with and without the frames to fields effect in Cinelerra.

and various combinations of the above.

I've also tried this: change the Cinelerra fps to 50, use fields to frames (instead of frames to fields), render to an intermediate QTforlinux jpeg video stream, re-importing that back into Cinelerra, adding a frames to fields effect and then rendering that output as normal (@25fps), and I still have the same problem.

Has anyone experienced this "jerking" playback before? Can anyone give any suggestions on how to fix it? (Like I say, it plays back fine on a PC, but not on any of the standalone players I've tried)

share|improve this question
    
@quack quixote: I don't see how those tag changes are any better. As you are a mod I thought I would ask for your reasons rather than just changing back myself. 1) Why split video-editing? How is "editing" on it's own a useful tag for this question (Or "video" for that matter). There are lots of video-editing questions on SU that would probably benefit from being grouped under this more specific tag. 2) Why remove the "Cinelerra" tag? This question is directly about this application, there is plenty of precedent for application name tags. –  Simon P Stevens May 19 '10 at 11:11
    
[video-editing] is no more. if you want to find video-editing questions search for video and editing tags. this way we don't end up with tons of [foo-editing] tags for everyone's favorite foo; just tag "foo" and "editing". i don't have a problem with a [cinelerra] tag, but it's been 9 months and yours is the only question with that tag. since you can only have 5 tags, i had to remove something. if you'd prefer to keep [cinelerra] and remove [linux] or [ffmpeg], go ahead. –  quack quixote May 19 '10 at 11:52
    
@quack quixote: Interesting point on the combined tag search. I'd still argue that separating the tags doesn't gain anything. By separating them I now can't mark "video-editing" as an interesting tag (or an ignored tag), and I'm not interested in most of the generic questions marked with just "editing". I don't see the problem with multiple "foo-editing" tags, it would allow people to filter to their specific tastes. Fair enough though, if that's how the SU community prefers it, I don't spend as much time on SU as I do on SO, so I'll leave it up to you. (Thanks for feeding back) –  Simon P Stevens May 19 '10 at 14:41

1 Answer 1

up vote 1 down vote accepted

I came back to this after a break and hit upon the solution. Thought I'd post it hear in case anyone else has similar troubles.

The solution was to pre-render all the video @ 50fps with a fields to frames effect set to top fields first. (Pre render using the most lossless codec possible, ideally RAW if you have the disk space). This pre-render extracts each of the interlaced fields to a separate frame (hence the 50fps)

Once you've done the prerender, create a new project with normal PAL settings (25fps interlaced bottom first) Then reimport the pre render back into Cinelerra (check that it detects the 50fps correctly). Now do your final render with a frames to fields effect set to bottom first. This takes the two separate frames from the pre-render and re-combines them into 1 interlaced field. This should now be correctly interlaced for DVD playback.

The thing to remember when doing this is: capture to match your source and encode to match your format. The sony miniDVDs I was capturing from were top first interlaced. I neglected to take this into account when doing my editing, so rendering straight to bottom first interlaced screwed everything up.

There's a good description of frames to fields here. Check out the bit underneath it about processing interlaced footage without deinterlacing it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.