Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed Windows 7 Ultimate x64. As all of my computers at home I've connected to my router via wifi (open/wep). And what has happened is that Wireless Connection is Connected but with No Internet access -- my ipconfig says:

Autoconfiguration IPv4 Address :
Subnet Mask :
Default Gatewawy : (empty)

After ipconfig /renew I get:

An error occurred while renewing interface Wireless Network Connection : unable to contact your DHCP server. Request has timed out. [..]

I'm looking for a solution for 2 hours now...


I've got a Linksys WRT54GL (w. Tomato) and I've already rebooted it with no effect. What is worth adding is that I've already have two laptops running WinXP that get IP from DHCP with success for months.

share|improve this question
Have you tried right clicking the network icon in the system tray and run "Troubleshoot problems"? – CGA Apr 10 '10 at 15:44
Try rebooting your router. – Travis Apr 10 '10 at 15:45
I have sometimes had problems with connecting to my wireless router, when my ethernet adapter was enabled as well. If you have an ethernet adapeter, try disabling it. Do try the other suggestions first though. – Om Nom Nom Apr 10 '10 at 16:57
Does not work :( – rafek Apr 10 '10 at 17:10
I have the same problem. The only thing that seems to work is when my Windows 7 64 is the only or first computer to connect to the router. – user40321 Jun 17 '10 at 20:26

Your computer can't contact/find a DHCP server on your network, and is not able to get a ip-address configuration.

Therefore you can't get connected to the internet. Try to reset your modem/router that does DHCP on your network.

If that doesn't work, look up the DHCP settings in your router/modem and check them. If you can't figure it out just copy them here so we can take a look.

share|improve this answer
That's not an issue.. Check my edits. – rafek Apr 10 '10 at 15:52
hmm... Have you installed the wireless network card drivers? instead of using the ones that came with windows ? I have had some problems with the windows drivers, where the official manufacturer supplied driver worked fine. – S.Hoekstra Apr 10 '10 at 16:34
@S.Hoekstra: My WiFi card is Pentagram HorNet P 6121-L6 there are no drivers for Win7 so Win7 uses its own. – rafek Apr 10 '10 at 17:09
Running out of ideas... You can try using the 64bit Vista drivers for your card. They are available on the support website of Pentagram. Vista drivers should work just fine (technically) in win7. – S.Hoekstra Apr 10 '10 at 17:35

this is an adress that you get if your computer is configurated for dhcp but can´t get an adress... are you sure your router is hosting dhcp?

share|improve this answer

The IP address you're picking up is a random one generated by Windows if it can't get an address from DHCP. That would indicate to me either a problem with the router DHCP service, or a connectivity problem.

Try picking a random unused address in the DHCP range, and set it manually on your laptop (with the correct subnet mask, and gateway) and see if that resolves the problem. If it does, it would suggest a problem with the DHCP server, and not a general connectivity problem.

It shouldn't be an issue if you're showing as connected but, have you tried checking your router to see if MAC filtering is turned on, it would explain why two existing machines work, but a new one won't.

share|improve this answer

Try ipconfig /release , then do an ipconfig /renew . I say this because there have been times where just 'renew' didn't cut it for some odd reason and I had to release first.

Like others have suggested try setting it to static values to see if that works at all & definitely make sure MAC filtering isn't on. Make sure you have enough addresses in your DHCP pool as well.

I personally would go ahead and right away answer the question of whether or not the wired connection is able to get an IP from this DHCP server at all to immediately rule out any general network/OS issues and narrow it down to just the wireless adapter. Also make sure you're able to get an IP on a different wifi network to truly determine whether it's the AP or the laptop itself. At least then you'd know where not to look most likely.

Another thing you can try is taking all security off the AP and see if it connects at all.

If you haven't tried the driver from the OEM install or the manufacturer's website then I'd do that as well instead of using the W7 default driver for it. Try the Vista driver if none for 7.

See if wifi works with a Linux LiveCD such as one from Fedora or Ubuntu. Preferrably a 64-bit one.

On Dell Latitude XT2 Tablet PCs at my work The Dell Wifi had like 6 components that had to be installed for it, it's ridiculous. But our 2 XT's with Intel Wifi only require 1 component. Maybe you're missing something like this.

If the OEM OS was 64-bit then maybe see if you can extract the driver from it to try out.

Turn off the Windows Firewall just to see. I'm not sure if Tomato firmware lets u do this but reserve an IP for your laptop's MAC on the Router so it will go into the list of knowns & maybe magically get an IP.

share|improve this answer
up vote 1 down vote accepted

The WiFi PCI card was an issue.. I've changed it to an usb one (tp-link) and now it works like a charm.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.