Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Slackware Linux 13.0 box with two interfaces, eth0 and eth1. I have set this box up to be on the 192.168.1.0/24 network, with subnet mask of 255.255.255.0.

I am trying to run a dhcpd server on this box to service two interfaces above, so I subnetted the 192.168.1.0/24 network into two subnets.

  • For eth0 192.168.1.1, subnet mask 255.255.255.128, broadcast mask 192.168.1.127.
  • For eth1 192.168.1.129, subnet mask 255.255.255.128, broadcast mask 192.168.1.255.

Both the interfaces are assigned manually.

eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:192.168.1.1  Bcast:192.168.1.127  Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1404 (1.3 KiB)
          Interrupt:11 Base address:0x8000 Memory:faffc000-faffcfff

eth1      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:192.168.1.128  Bcast:192.168.1.255  Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10003 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13286 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1589229 (1.5 MiB)  TX bytes:9900005 (9.4 MiB)
          Interrupt:11

Here is the dhcpd.conf set up

authoritative;
ddns-update-style interim;
ignore client-updates;

subnet 192.168.1.0 netmask 255.255.255.128 {

     range 192.168.1.2 192.168.1.126;
     default-lease-time 86400;
     max-lease-time 86400;

     option routers 192.168.1.1;

     option ip-forwarding off;

     option domain-name-servers 208.67.222.222, 208.67.220.220;

     option broadcast-address 192.168.1.127;
     option subnet-mask 255.255.255.128;
}

subnet 192.168.1.128 netmask 255.255.255.128 {

     range 192.168.1.129 192.168.1.254;
     default-lease-time 86400;
     max-lease-time 86400;

     option routers 192.168.1.1;

     option ip-forwarding off;

     option domain-name-servers 208.67.222.222, 208.67.220.220;

     option broadcast-address 192.168.1.255;
     option subnet-mask 255.255.255.128;
}

This is what is showing in the log

Apr 10 18:09:58 inspiron8600 dhcpd: DHCPDISCOVER from 00:00:00:00:00:00 (inspiron8600) via eth1
Apr 10 18:09:58 inspiron8600 dhcpd: DHCPOFFER on 192.168.1.131 to 00:00:00:00:00:00 (inspiron8600) via eth1
Apr 10 18:10:01 inspiron8600 dhcpcd[3832]: eth1: adding IP address 169.254.153.6/16

This is happening spuriously, and the log gets filled up with nonsense..it should be noted that 'inspiron8600' is the linux box that is running the dhcpd server. So my question is this:

How do I stop this from happening? And why would it be trying to give itself a lease?

I am sure I have missed something but cannot see it and would appreciate a pair of eyes from the community to spot the obvious flaw!

To mention, the MAC's have been filtered out and replaced with 0's to protect the guilty!!!

share|improve this question

2 Answers 2

Its strange behavior.

  1. Its not answer but HWaddr 00:00:00:00:00:00 look wery strange!
  2. Not strange that the dhcp server gives the address for self host. It give address for everybody who ask. Strange why dhcp client ask!
  3. If dhcp clien functionality not necessry dhcpcd (DHCP Client Daemon) can be stopped and disabled.
share|improve this answer
    
I deliberately removed the MAC's.... :) regardless as I do not want to publish the mac's...the dhcpd log shows that the dhcpd daemon is trying to give itself a lease which it should not happen... –  t0mm13b Apr 11 '10 at 13:34

I hope this isn't a dumb question, but have you checked to make sure you don't have dhclient or dhcpcd (I don't know which one Slackware uses) still running on the system? In Slackware you may still have to disable the DHCP client daemon manually, depending on how you assigned the system's static IP addresses.

Does the following command show anything running?

ps -C dhcpcd,dhclient
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.