Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got an ASP.NET application that I have in IIS on my Windows 7 Ultimate machine. I've tested it from that machine and it works fine. This machine is in my home network, a simple peer-to-peer network. The strange thing is that no one else in my network can access that website. Why is that? There are other Windows 7 machines here, and they're all in the same homegroup. When I attempt to access the website on my machine from one of the other machines, it fails and that's it.

So, what's wrong?

share|improve this question
up vote 3 down vote accepted

The first thing I would check is your firewall settings. If it works with the firewall disabled, then re-enable the firewall and open port 80 (for HTTP) for incoming connections. You may have to open other ports for other services like FTP.

share|improve this answer
    
I'm not sure if I've done the right thing of not, but I disabled my AV (which is VIPRE) and tried it from another machine on my P2P network. It still timed out trying to connect. – Rod Apr 12 '10 at 0:59
    
A firewall is different from antivirus. A firewall prevents or allows certain types of connections to a PC. If you don't know what firewall you are running, then it's probably the Windows Firewall. Open Control Panel (Start > Control Panel) and find the Windows Firewall application. Disable it temporarily and test the connection. If that works, then enable it and add an exception for IIS. – Wayne Johnston Apr 13 '10 at 3:01

Go to Control Panel -> Windows Firewall - Click advanced settings, Rules for incoming traffic, in my case i had to enable World Wide Web services - (Incoming Traffic) NOTE: I found 2 "World Wide Web services - (Incoming Traffic)" you have to enable them both

Before this i also mapped port 80 on my router, but it started working after i enabled those firewall rules.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .