Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I close a tab in Chrome, it makes a click sound. How do I turn off that sound?

I reported that issue back in Oct 2010. The problem doesn't appear on all clients and the reason is still unclear.

Common attempts at solving the issue include simply turning off the sound in Windows. But I would prefer to solve the problem at the source.

Why is Chrome even triggering that sound to be played? And why is it delayed? The problem would be far less annoying if the sound could easily be related to the action taken.

  • Installing the Chrome Toolbox and muting all tabs has no effect on this issue.
  • When switching to a different Chrome user profile, the new user profile does exhibit the same issue.
share|improve this question
7  
Google chrome doesn't make sounds when closing tabs (or anything else) as far as i know. Do you run any extensions that might be doing this? Else you can check the sound settings of your Operating System. –  S.Hoekstra Apr 11 '10 at 12:33
    
Only adblock is installed. This didn't happen until recently. I don't know whether its chorme or the OS, but a clicking sound appears when a tab is closed nontheless. –  nos Apr 11 '10 at 12:56
    
Does this happen when you close a tab using the keyboard (Ctrl-W) and/or the mouse? –  bentsai Apr 14 '10 at 17:51
    
I think this has to do with the current process model setup in chrome. Try changing –  SnOrfus May 25 '10 at 5:10
3  
I get a sound, too. It does not occur with CTRL+W, but does if I use the mouse. It also plays when I hit buttons on the menu bar. There's no mention of this in the settings/preferences... so I'm muting my whole audio system to solve it. I'm on Ubuntu 10.04. Help! –  Yetanotherjosh Jun 19 '10 at 2:07

3 Answers 3

This annoying problem appeared spontaneously while I was browsing.

It is simply solved by closing all folders(windows explorer windows).

I can't say what triggered it, but I can say that I've had a few pdf files (stored on my computer) opened in Chrome. I've also had ONLY the current Donwloads target folder opened. These could all be possible triggers.

share|improve this answer

For completeness sake, it should be noted that (at least in mine and someone elses case), rebooting the computer fixes the issue.

I rarely reboot, so the problem doesn't fix itself for me.
Also, this is a temporary fix for the issue. Something triggers it to reappear some time in the future, I just can't figure out what it is.

Investigation

I tried to see what API functions are invoked by Chrome when the issue appears. For that, I ran the 32bit API Monitor and added a capture filter for calls into winmm.dll.

I checked if Chrome even calls PlaySound (assuming that's how the sound is played) and it seems like it doesn't. I see a lot of other stuff happening when a tab is closed. But I wasn't able to pinpoint anything as the cause of the sound.

I'm now more confident that, while Chrome is the cause of the sound, it does not directly invoke it. I'm currently assuming that an action Chrome is taking is causing another process to emit the sound.

While investigating a few minutes ago, I started killing processes to see if and when the click sound would stop.

It stopped after closing all Windows Explorer windows. At this point it's unclear if there is any relation between Windows Explorer and the click sound being emitted. It'll have to wait for another day.

After the issue just happened again, I ran another Process Monitor recording and double-checked my Windows Explorer theory. Look what I got:

enter image description here

After closing the 2 open Explorer windows, the clicking was gone again.

In light of this new information, I decided to post another bug report.

share|improve this answer
    
See this discussion & this forum help may be they work for you. –  avirk Apr 29 '12 at 0:44
    
"Surely a virus." ahhahaahahahhaha. Anyway, reboot solved for me. For now at least. The CTRL click is a good one on the mailing list. –  Shiki Sep 25 '12 at 9:21
4  
Closing all open Explorer windows worked for me. –  kpozin Feb 1 '13 at 14:28
1  
Closing all open explorer windows worked for me, definitely worth trying if you're experiencing this issue. –  Dereleased Mar 12 '13 at 10:32
    
This definitely worked. Thanks! –  Ashitaka May 5 '13 at 21:19
  1. Go to Control Panel.
  2. Open Sounds. (In Windows 7 It's called Sounds not Sounds and Audio Devices)
  3. In Sounds tab on Windows Explorer section, select Start Navigation
  4. On Sounds section, select (None) on the drop down menu.
  5. Apply then OK

enter image description here

Kudos for HowToGeek for supplying this nice image

Related question Windows 7 'click' sound

share|improve this answer
3  
Here is the link to the original post on the Chrome forums. –  Sharken Jun 9 '11 at 20:44
2  
What if he wants the clicking in other programs? This doesn't fix Chrome, specifically. –  ekaj Apr 24 '12 at 22:11
    
Any ideas how to do the same thing in KDE? –  David Doria May 12 '12 at 0:51
5  
Um, no! This only hides the problem, it does not fix it. Chrome has never used the sound before; something has changed (that is not supposed to have). Simply muting it is not a solution! (Patient: It hurts when I breathe. Doctor: Then don’t breathe.) –  Synetech Dec 5 '12 at 15:46
    
To me this is the best solution. Honestly the sound is annoying no matter where it is played. I really hate it when I get this sound as I'm navigating folders in Windows Explorer. Yes it should be classified as a bug for how the sound is played in Chrome, but I'd say it's totally worth it to just disable this sound for the entire system. I don't get why Microsoft even introduced this junk setting and gave it a default sound. –  ADTC Oct 19 '13 at 19:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.