Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My IE8 has suddenly started defaulting to the 64-bit version. I have no idea how or why this has happened, but I suspect it might be linked to the Browser Choice Screen that Microsoft was recently forced to display by EU law.

However, many web sites will not display correctly in IE8 x64 (eg. sites that use Adobe Flash or Microsoft Silverlight). I have the 32-bit version of IE pinned to my taskbar and if I launch it manually, everything is fine. But when I click on a URL from another program and IE is not already running, then the 64-bit version gets launched. This really messes with programs like BBC iPlayer which rely heavily on Adbobe Air and Flash.

So, how do I get IE8 32-bit version to be the default version again? I've tried using the "default programs" control panel and that doesn;t make any difference (in fact, it doesn't give the choice between x84 and x64 versions, it just lists "internet explorer").

share|improve this question
    
well, I can't think of anything except to try setting IE as default in "Internet Options" (Control Panel) under the programs tab, it should default to 32 bit, but due to your descriptions I don't think it'll work. –  Vervious Apr 11 '10 at 17:16

4 Answers 4

Try editing the registry. Make sure to open the 64-bit registry editor. (you have to close the 32-bit one first).

Go to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command and set the (Default) value to the path (from the 64-bit point of view) of 32-bit IE, which might be "C:\Program Files(x86)\Internet Explorer\IEXPLORE.EXE" -nohome (the "-nohome" is a commandline option which my copy of IE8 adds to this value)

You might want to do the same for the classes https and even htmlfile if you want to double-click HTML files and open them in 32-bit IE.

All this won't help if a 64-bit application executes iexplore.exe directly instead of launching a URL. (in fact I haven't tested my suggestion at all because I don't have 64-bit Windows. Nevertheless it might work)

share|improve this answer

try changing the defaults in:

control panel > programs > default programs > set associations

share|improve this answer

I ran into this problem when opening links in Outlook 2003 on Windows 7 64-bit. The links by default would open the 64-bit Internet Explorer 8 and therefore required third-party plug-ins would not be loaded.

I found a few places in the registry where the default IE is identified by its path and they need to be changed.

Copy the text below the dotted line (Windows Registry... should be first line copied) to notepad and save the file as IEdefaults.reg to your desktop. Double-click the file on your desktop to merge the registry information. Be sure to backup the registry beforehand, but all that’s being modified are the paths to Internet Explorer, where “ (x86)” is added next to Program Files. The locations can also be updated manually if you don’t want to create the registry file. Just find the locations in the registry and add “ (x86)” (without quotes).


Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_CLASSES_ROOT\htmlfile\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\https\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" -nohome"
share|improve this answer

i did came across similar situation recently. i kind of worked it around and it works fine now. here is what i did

  1. access *c:\program files (x86)\internet explorer*
  2. copy iexplore.exe "which would be a 32bit version"
  3. now i went to *c:\program files\internet explorer*
  4. rename iexplore.exe to anything else and paste iexplore.exe from *c:\program files (x86)\internet explorer* here

try access internet, it would always open 32bit version. not much fiddeling around with registry and all.

You can try doing the same if iexplore.exe 32bit is corrupted or troubling you

share|improve this answer
    
Although this will work (as your actually deleting the 64bit version), I wouldn't recommend it to anyone ever. There are far simpler ways. –  cjb110 Apr 15 at 13:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.