Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install my wireless drivers (which uses a broadcom card). I tried to install them using the restricted drivers offered on my Ubuntu CD (since my only internet connection is public Wi-Fi). However when I clicked activate it got about halfway through the install process before it gave me this error message:

SystemError: installArchives() failed

The driver in question is this one: Broadcom STA wireless driver

How can I correct this?

share|improve this question
    
So it fixed itself? I'm not sure how but as of today I turned on my PC and now it works. –  Lucas McCoy Apr 16 '10 at 19:27

4 Answers 4

up vote 2 down vote accepted
+100

I have Broadcom wireless also, it isn't that good but it get the job done. I think it would be better if we could know the exact model, because depending that you will need a driver or another:

lspci

Also it would be nice to have the

dmesg | tail

output for knowing what error is exactly.

But anyways, there are a lot of options involving this chipset: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

share|improve this answer
    
The model number reported from the output of lspci is bcm4312, but as I said in my comment on my question, now the wireless card is working. –  Lucas McCoy Apr 17 '10 at 13:47
    
I gave the bounty to you because I figured you were on the right trail. ;-) –  Lucas McCoy Apr 20 '10 at 1:19

10.04 is still in beta. I would try 9.10 Live, if you can get it working on that one you know that it's a problem with 10.04. If that's the case, than you could file a bug report about 10.04 and you're card.

share|improve this answer
    
I tried 9.10 and it didn't work so I uninstalled it. I figured 10.04 would have that fixed, but of course they didn't. –  Lucas McCoy Apr 11 '10 at 21:35
    
bcm43xx.berlios.de/?go=devices –  Algific Apr 12 '10 at 4:26

FWIW, I discovered that the "patch" package wasn't installed, and that's where the kernel source build was failing. Installed that and it worked.

share|improve this answer
1  
Would be nice if you could mark this as the solution to your question. –  Oliver Salzburg Feb 28 '12 at 14:03

After upgrading to Ubuntu 10.04 I had the exact same problem! To solve it:

  1. Open Synaptic Package Manager
  2. Type "broadcom"
  3. Right click on "bcmwl-kernel-source" and mark it for re-installation
  4. Go back to the hardware drivers where you should now be able to activate the broadcom driver without any problems.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.