Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have several Debian lenny computers. Two have nearly identical sources.list files. On both, I do regular update/safe-upgrades. On one it always goes smoothly. On the other, much of the time I get the following:

 sudo aptitude safe-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Reading task descriptions... Done  
The following packages will be upgraded:
  krb5-clients krb5-ftpd krb5-rsh-server krb5-telnetd krb5-user libimlib2 libkadm55 libkrb53 libpng12-0 libpulse0 xpdf xpdf-common 
  xpdf-reader 
13 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 2906kB of archives. After unpacking 36.9kB will be used.
Do you want to continue? [Y/n/?] 
WARNING: untrusted versions of the following packages will be installed!

Untrusted packages could compromise your system's security.
You should only proceed with the installation if you are certain that
this is what you want to do.

  krb5-rsh-server krb5-user krb5-ftpd krb5-clients libkrb53 xpdf-reader libpng12-0 libkadm55 xpdf libpulse0 libimlib2 krb5-telnetd 
  xpdf-common 

Do you want to ignore this warning and proceed anyway?
To continue, enter "Yes"; to abort, enter "No": no
Abort.

Needless to say, I don't proceed. What is going on? How do I fix it? These are the non-comment lines in the sources.list for this computer:

deb ftp://ftp.debian.org/debian/ lenny main contrib non-free
deb-src ftp://ftp.debian.org/debian/ lenny main contrib
deb http://security.debian.org/ lenny/updates main contrib non-free

Thank you.

share|improve this question
    
I don't know the answer, but I do know that this is a very common problem. I have it too (with different packages). I googled for "WARNING: untrusted versions of the following packages will be installed" and got over 80 hits - with no answers to any of them. –  user53392 Oct 24 '10 at 19:30
    
OK, good to know I'm not alone. Oddly enough, a few weeks ago the problems suddenly ceased and I have been able to upgrade smoothly since. I hope that continues. –  Liam Oct 25 '10 at 2:21
add comment

1 Answer

Kstars in wheezy is unsigned, so are lots of other things. Either the repositories are compromised, or someone is asleep at the wheel.

share|improve this answer
    
This does not appear to answer the question that was asked. –  Mokubai Nov 23 '13 at 7:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.