Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since I've been using Windows 7 Retail (as opposed to the Beta and RCs), I've been having a peculiar issue with executable files. I first noticed it whilst using Visual Studio, in that when building a project, it would often fail saying that the output file was locked - but the problem has stemmed further.

When I've executed an application, closed it (cleanly), and attempted to delete/move/rename/overwrite said file, Windows 7 tells me that the file is locked/access is denied. I've made use of software like LockHunter/Unlocker but it is seemingly unable to remove these locks (most of the time, it shows no locks at all). After about 5-10 minutes, the respective files are unlocked again, but needless to say this is a bit of a workflow-breaker (as it's not simply constrained to VS).

I've done the usual tasks of virus/malware scanning, and turned up with absolutely nothing. I've got no peculiar services running, and the problem was not present before I installed a Windows 7 Retail version.

Any help is greatly appreciated.

share|improve this question
1  
Deleted my answer since you updated your question. –  th3dude Apr 12 '10 at 18:07
add comment

1 Answer

up vote 1 down vote accepted

I have a feeling that the culprit is Windows Indexing Service.

While I haven't run into such a problem myself, I read (as far as I remember, while installing TortoiseSVN or TortoiseHG on Windows 7) that there are file lock problems sometimes with the Indexing Service. Basically, the Service is trying to index the file, so it locks it while it does that.

I'm not sure if this is the right answer to your problem, but I recommend you try configuring the Indexing Service's settings, or just disable it for our development directory.

Here's some of the stuff that's written in the TortoiseSVN FAQ about a similar problem to this:

This error message typically occurs when you try to update or commit your working copy, and seems to be common on Windows 7 systems. It is due to another process holding a handle on a file that Subversion needs to move or modify. This might be a virus scanner, but on Windows 7 it is likely to be the Windows Indexing Service. Turn off the indexing service on your working copies and repositories, and exclude them from virus scans.

Hope I helped!

P.S.: I might update this answer later on with a guide to configuring the Indexing Service.

share|improve this answer
    
Will take a look at this later (when I have access to my machine again) - but have upvoted in the meanwhile for a helpful answer :) –  James Burgess Apr 13 '10 at 8:45
    
Have accepted this answer for the time being - as I haven't had any issues since disabling indexing for those locations. Thanks. –  James Burgess Apr 14 '10 at 13:57
    
My indexing is disabled from the get go. The problem still exists though. –  AndreyT Feb 16 '13 at 0:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.