Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I just built myself a reasonably beefy computer, and I installed Windows 7 on it. However, I start the machine up each morning and within a few minutes, the computer will semi hang.

That is the mouse is responsive, and most of the time I can open task manager, or a new tab in Chrome. Occasionally windows will be labelled as 'Not responding'.

Then, the machine will get over it's problem, and will be nice and quick until I turn it off.

Here's my specs:

  • CPU: AMD Phenom-II X4 955 Black (Quad Core, 3.2ghz)
  • RAM: 4GB of DDR3 1300
  • MOBO: ASUS M4A785T-M (Latest BIOS)
  • HARD DRIVES: 2x1TB Western Digital Caviar Blacks in RAID-0.
  • OS: Windows 7 Ultimate x64.
  • GPU: ASUS GT240 1GB.

I believe this issue relates to the RAID array, as I didn't have the lockup problem before I created the array. I purchased a second drive and reformatted after creating a RAID array, since the single drive was a little on the pokey side (compared to the rest of the computer).

What I have tried:

  • Updated Raid Drivers
  • Malware checks
  • Windows Updates
  • Unecessary Services
  • CPU and Disk activity appears to be low (via Resource Monitor)
  • No strange errors in the error log.

Any thoughts?

share|improve this question
Have you tried a new operating system? – Josh K Apr 12 '10 at 20:59
No. Since this is a work machine, I'd prefer that to be a last resort. – EvilChookie Apr 12 '10 at 22:33
up vote 3 down vote accepted

Try Process Monitor from Sysinternals. It can be configured to do real-time boot logging of all process, registry, file system, and network activity. Let it capture until the system hang stops, then look at the log to see what was going on during the hang time. You can usually spot something if it looks unusual.

share|improve this answer
I found that MS Security Essentials was taking a significant amount of time at startup - I added it's process and folder to the exclusion list, and I've read a few documents on the 'net that may suggest this might help. – EvilChookie Apr 13 '10 at 3:55
So I removed MSE, and my computer hasn't chugged up since. It was ProcessMonitor that allowed me to figure it out, so you get the answer. Thanks! – EvilChookie Apr 15 '10 at 22:36
Yeah, the tools at Sysinternals are great. Just so you know, they have forums that are also full of good info. – Joe Internet Apr 15 '10 at 22:57
  • Does it do it when booting in to safe mode?
  • Try using msconfig to enable a boot log.
  • If you can get to task manager, sort by cpu descending, look for anything with high usage.
  • Try booting with no network connectivity; if it doesn't do it then, it could be an extension to explorer trying to connect; use autoruns to disable unnecessary explorer extensions

...or just go get coffee while it boots.

share|improve this answer
I'll do a safe mode boot, and msconfig boot load and see what that reveals. As I mentioned in the OP, CPU and Disk Activity are low. I also checked the autoruns, and didn't find anything out of the ordinary. It's a brand new machine and I've installed very little. – EvilChookie Apr 13 '10 at 3:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .