Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

From this morning something strange is happening to my Notepad++ editor. When I press ↵ Enter on the keyboard I get some strange symbols:

screenshot

What can I do to fix this?

share|improve this question

migrated from stackoverflow.com Apr 13 '10 at 1:05

This question came from our site for professional and enthusiast programmers.

it's an view option, turn it off via view -> "show end of line"

share|improve this answer
1  
On mine it's under View -> Show Symbol -> Show End of Line – Cameron Apr 12 '10 at 12:43
    
this is the right answer I can't accept it yet – user24795 Apr 12 '10 at 12:44
    
I think it's in different places in different versions. I have version 5.6.6. – Cameron Apr 12 '10 at 12:54

Indeed, you're seeing control characters in your view. Just for fun, a little bit of CR/LF history.

share|improve this answer

You've probably turned on some mode that displays control characters. CR-LF (\r\n in C parlance) is the standard end-of-line sequences in Windows.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .