Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running GNOME (gnome-session under xmonad). I want to turn off antialiasing (i.e. use monochrome mode) for fonts in gnome-terminal. But I want to retain antialiasing for other applications, like Firefox. Is this possible?

Antialiasing is great and almost necessary for using Firefox or Chrome. But it makes the fonts in gnome-terminal blurry at sizes around 12 or smaller.

Otherwise, I'll just have to use xterm, which seems not to anti-alias its fonts under any circumstances.

share|improve this question
    
I have the same issue with xmonad.. Did you solve it? –  Jakub M. Jun 19 '12 at 14:44

3 Answers 3

Not sure if this actually works, but you could try to use .Xdefaults to configure this. Make a file named .Xdefaults in your home dir. Put in the following:

Xft*antialias: false

Effects everything!!! Just find the right name, and it should work.

share|improve this answer
    
That didn't work, sorry –  dan Apr 13 '10 at 15:00
    
Sorry, fixed it! And it works, checked! –  Algific Apr 13 '10 at 15:54
    
Damit! That seemed to effect everything. But that file is the answer! read about it =) –  Algific Apr 13 '10 at 15:57

Why not try using a decent anti-aliased TrueType monotype font, a la terminus? It looks great at nearly any size. On Ubuntu/Debian the package is named xfonts-terminus.

share|improve this answer

As for I only want to use the courier new font size 10 in the terminal, here is how I finally made it. With this way, only courier new 10's antialias is disabled, which makes everything else is the same as before.

And you may get more information from font configuration and this question

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
    <match target="font">
        <test name="family">
            <string>Courier New</string>
        </test>
        <test name="size" qual="any" compare="EQ">
             <double>10</double>
        </test>
        <edit name="antialias" mode="assign">
            <bool>false</bool>
        </edit>
    </match>
</fontconfig>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.