Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accidentally opened a Java file with Firefox and now I cannot change this... How can I make JCreator default again?

Here is example of my problem:

alt text

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

This is simply because you changed the default for that registered filetype, this is easy to change back.

In any explorer window (you can use that one you have open in the picture) go to:

  • Tools -> Folder Options -> "File Types" tab
  • Scroll down the list to find the .java extension
  • Highlight the .java selection.
  • Where it says "Opens With:", click the "Change..." button and choose JCreator.

alt text

share|improve this answer
add comment
  • Right-click on the file.
  • Click "Open With". If this opens a submenu, select "Browse" (I think).
  • Select "Select a program from a list of installed programs".
  • Out of the list, select JCreator.
  • Check the checkbox that says "Always use the selected program to open this kind of file", and hit Enter.
  • You're done.

I'd post a screenshot, but I'm running Vista so mine is a bit different. If anyone is willing to contribute, feel free to leave a link to the screenshot in a comment and I will edit my post. :)

share|improve this answer
    
I try this but checkbox is grey –  demetri Jul 26 '09 at 3:06
1  
Hmm, interesting. The only time that has ever happened with me is with files with no extension. Oh well, I'll keep the answer here because it's easier than the other suggestion, IMO. –  Sasha Chedygov Jul 26 '09 at 3:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.