Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have debian system in which i have mounted the OS on a ext-3 system . I have got a partition of 60 gb , which is formatted to ext-2 partition . Even if I mount , i cant write anything into it . How can i change that ? How can I make the disk writable?

share|improve this question

migrated from stackoverflow.com Apr 13 '10 at 12:04

This question came from our site for professional and enthusiast programmers.

2 Answers 2

If you didn't mount the partition read only, then you should be able to write to it once it's mounted. Except if the user trying to write does not have write permissions to it.

share|improve this answer
    
i am not really sure what should be the command to mount it as writable . And i am doing sudo when I mount it. so i think i have the permissions.. –  kasperasky Apr 13 '10 at 12:04
    
If you didn't wrote special options to the mount commands, then it is most likely the partition is mounted read/write. Check if your user has the permissions to write to the directory where the partition is mounted, or use superuser (sudo touch /path/to/mounted/directory/foo). –  Didier Trosset Apr 13 '10 at 12:09

The partition might need to be 'checked.' Run fschk on the partition BEFORE IT IS MOUNTED.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.