Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a VM set up through Windows Virtual PC for Windows XP Pro and I have been completely unable to get ClearType to work.

I have turned it on in the Display -> Appearance -> Effects dialog but it seems like it completely ignores this. All text is still without any anti-aliasing. Even setting it to normal smoothing doesn't work. If I disable Integration Features, it seems to work, but then I lose a lot of nice features.

What's weirder, is that the Windows XP Mode installed with Windows Virtual PC (this is separate from my XP Pro VM) works with both ClearType and Integration Features just fine. I turned it on the same way and it works like a charm, no problems.

I'm running Windows 7 Professional 64-bit as the host OS and have the latest (to my knowledge) Windows Virtual PC installed. The only funny business I can think of is that I've enabled 24-bit color via the Group Policy setting inside each XP virtual machine (both Pro and the stripped down XP mode copy). This is a fairly well-known trick documented all over the web, but here's a typical post about it.

share|improve this question
    
I, too, have enabled 24-bit color and am having difficulties getting ClearType enabled. My intuition tells me that ClearType only works with True Color (32 bit). –  Paul Lammertsma Apr 29 '10 at 12:16

2 Answers 2

up vote 2 down vote accepted

at least in Windows 7 64-bit Windows Virtual PC (I'm using the Windows XP sp3 IE7 VHD), you can have "Integration Features" enabled and have ClearType working in Internet Explorer 7 at the same time.

found the first part of the information here:

http://www.mydigitallife.info/2009/12/16/how-to-increase-color-depth-and-quality-of-windows-xp-accessed-via-remote-desktop-or-terminal-services/

First, disable Integration Features before continuing with the procedure. After changing the maximum color depth limit, re-enable the integration features.

  1. In the Windows XP operating system (remote system), click on Start menu, then Run.
  2. Type GPEdit.msc to open Group Policy Editor.
  3. Navigate to Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services.
  4. In the right pane, double-click on the Limit Maximum Color Depth setting.
  5. In the Properties dialog, select radio button of Enabled, and then set Color Depth value to 24 bit.
  6. restart the image by going to ACTION > RESTART (very top left of the Windows Virtual PC program).

then from this link:

[can't post second link because I'm a new user, but the page name is "Virtual PC for Windows 7 HORRIBLE - or am I missing something?"]

  1. In the Windows XP operating system (remote system), click on Start menu, then Run.
  2. Type regedit to open the Registry Editor.
  3. Navigate to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations]
  4. add a new DWORD called "AllowFontAntiAlias" (without quotes) and set the value to one. The value will display as "0x00000001(1)"
  5. restart the image by going to ACTION > RESTART (very top left of the Windows Virtual PC program).

you may or may not have to restart between each step, but I did. After this, I had the "Integration Features" enabled with ClearType working in Internet Explorer 7 in Windows Virtual PC.

share|improve this answer
    
I thought I had compared everything and there were no differences except one: I must have done the AllowFontAntiAlias trick on the XP Mode VM and forgot that step when setting up the XP Pro VM. I had no trouble getting 24-bit color to work on both but Pro refused to accept the ClearType setting (it did nothing). Sure enough, XP Mode VM had the registry setting set. I put that on the Pro side and restarted it and it works now. 24-bit color, ClearType, and Integration Features. Finally! –  Sean Hanley Oct 5 '10 at 16:13

The only way I have found to do this, is by disabling integration features. Evidently, the integration features make everything run through terminal services, which doesn't support more than 24-bit video.

I've disabled integration features, ramped the color depth up to 32 bit and enabled ClearType. Unfortunately the video performance is rather poor as it uses XP's software rendering (opposed to hardware acceleration).

The only ill effects of disabling the integration features is that XP Mode doesn't automatically log in and that you can't drag and drop as seamlessly as before.

share|improve this answer
    
That's been my experience, except for the Windows XP copy that comes bundled with XP Mode when you install it. This one works with Integration Features, 24-bit color, and ClearType all just fine, no problems, no crappy software rendering. It's the manually created Windows XP Pro VM that has the mysterious trouble. It's either ClearType or Integration Features but not both with it. Strange. –  Sean Hanley May 4 '10 at 16:32
    
The same holds for XP Mode under Windows 7's Virtual PC; exactly as you say: either ClearType or Integration Features, not both. –  Paul Lammertsma May 5 '10 at 22:06
    
FWIW you can run with 32 bit colour and the integration features enabled with a bit of hackage. See step 3 at articles.sitepoint.com/article/ie6-ie7-ie8-win7-xp-mode. Unfortunately it doesn't solve the ClearType problem. –  Simon Lieschke May 25 '10 at 2:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.