Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

IE has an annoying problem on my PC (XP SP3). I start it and try to go to Google (for example) and it'll sit there saying "Connecting" but nothing will happen and it doesn't matter how many times I try, it won't connect to anything.

I discovered that if I kill IE and restart it then it might start working (and then it'll work every time). It might takes 3-4 restarts (of IE, not the PC) to get a working IE.

Now I wouldn't normally care about this since I use Chrome but a lot of things use IE by default like Windows Update and the online help in Office 2003 so I would like to fix it.

Interestingly, my work laptop, which is running Windows 7 RC 64-bit, has exactly the same problem (completely different network and everything). I'm utterly convinced it's not a network or hardware problem but some software problem.

Edit: More info.

  • It's IE8;
  • No add-ons;
  • Automatically detect settings is not enabled.
  • It is set to "Never dial a connection".
share|improve this question
    
do you have any addons? and what version of IE? –  John T Jul 26 '09 at 4:31
1  
Do you use fiddler? –  Hafthor Jul 26 '09 at 6:05
1  
I occasionally have the same problem but it's when IE is already running. Certain tabs stop working altogether. –  Alex Angas Aug 14 '09 at 15:07
    
I've had the same problem, however I must say I never tried restarting IE 3-4 times, I just restarted my PC & it worked every time. Still haven't found a fix. I, too posted on here but never found an answer... –  kpoehls Aug 14 '09 at 16:29
    
That is too funny, I figured I was the only one. It's been going on for quite a while with my computer –  Breadtruck Aug 21 '09 at 6:42

13 Answers 13

Most likely you have the "Automatically detect settings" option selected in -> Internet Options -> connections. It goes out and tries to decide on its own the best way to get you to the internet. It can get hung up for a while trying to find a proxy to talk to. Removing this option will cause it to speed up.

Another couple of notes here is that if your computer is set to dial a connection it could also hang up like this while it is deciding what to do. Setting your connections to "I am on a local area network" can fix this issue too.

This does not sound like a browser in offline mode as it usually is kind enough to tell you about that.

share|improve this answer
    
"Automatically detect settings" actually works if you have WPAD setup correctly... Otherwise it will cause a delay only at the first visit of a web page, because it is waiting for a DHCP inform request to time out. –  Jeroen Landheer Aug 19 '09 at 14:39
    
Thanks, worked for me. –  jfar Sep 9 '09 at 16:03

It could be a slow DNS lookup.

If the problem recurs when you try to go to google.com, instead try going to http://74.125.45.100/ which is one of many IP addresses for google. This will bypass the DNS lookup. If the page loads quickly, then we know to look into DNS.

share|improve this answer

I would have to agree with the " automatically detect settings" option posted previously. 9 out of 10 times this is the culprit. Make sure this is NOT checked.

share|improve this answer

Do you start typing into the address bar as soon as IE loads up? I find that I need to wait for a couple of seconds - sometimes half a minute and only then try to use it...

share|improve this answer

I got this problem too, exactly an XP SP3 but with IE6. I got the fix but don't know why!

  • Got to network and sharing center
  • Create a new DSL Connection (you'll need to input your username and password, from your ISP)
  • Connect to it.

You may think it's stupid, since it's unrelated; but it fixed the problem.

share|improve this answer

Could be a DNS issue...

Go to command prompt Type ipconfig /flushdns (do this multiple times, just to be sure) then type ipconfig /registerdns

See if it works

You might have to close ie and open again after flushing dns.

share|improve this answer

Have you tried to remove the IE8 update and reinstall it.

Also for those pages that require IE you could use Firefox with IE Tab or do this in Chrome:

Old 04-16-2009, 06:32 PM klliopatra klliopatra is offline Junior Member Join Date: Apr 2009 Posts: 1 Lightbulb IE Tab Instructions in Everday Language Hi everyone,

I just figured it out by putting together the various instructions. Here are instructions in everyday non-techie language:

  1. Go to http://www.meadroid.com/neptune/ and click D-LOAD to install the software.

  2. After it is done installing, open the folder C:\Program Files\MeadCo Neptune. You will see a file called npmeadax.dll.

  3. Right-click and copy npmeadax.dll.

  4. Open the following folder (enter your Windows username where it says [$username]):

  5. In XP -- C:\Documents and Settings[$username]\Local Settings\Application Data\Google\Chrome\User Data\Default\Plugin Data\

  6. In Vista -- C:\Users[$username]\AppData\Local\Google\Chrome\User Data\Default\Plugin Data

  7. Paste npmeadax.dll into this folder.

  8. Click Start --> Run.

  9. Type cmd and press enter. A black and white window will pop up with C:> and a blinking cursor.

  10. Type the following command starting with cd and including the quotation marks and press enter (enter your Windows username where it says [$username]):

  11. In XP -- cd "C:\Documents and Settings[$username]\Local Settings\Application Data\Google\Chrome\User Data\Default\Plugin Data"

  12. In Vista -- cd "C:\Users[$username]\AppData\Local\Google\Chrome\User Data\Default\Plugin Data"

If you do it currectly then that long string of the folder path will appear in front of the > character next to the blinking cursor.

  1. Type dir and press enter.

  2. You should see npmeadax.dll in the list on the right (probably listed under Google Gears). If you don't see it, then you didn't copy it correctly. Go back and copy it again.

  3. Type regsvr32 npmeadax.dll and press enter.

  4. You should receive a message saying that it was successful. Click ok.

  5. Go into Google Chrome.

  6. Turn on the bookmark bar by typing CTRL+B while in Google Chrome (if it's not on already).

  7. Create a bookmarklet by dragging the text in the box below to the toolbar:

Code:

javascript:(function (){var lh=location.href; if( !lh || lh.match(/^(javascript|about):/i) )return; document.write(''+(document.title?document.title:lh).replace(//g,'>')+' - using Internet Explorer rendering<\/title><\/head>var script = document.createElement(\'script\'); var embed = \'<\/embed>\'; script.setAttribute(\'src\',\'data:text/javascript,document.write(embed);\'); document.body.appendChild(script);<\/script><\/body><\/html>'); })();

The default name will be "Untitled" but you probably want to rename it something like "IE Tab."

  1. Go to a website that only works with IE, click your IE Tab button, and try it out!

Hope this helps!


Klliopatra Last edited by klliopatra; 04-17-2009 at 12:07 AM.. Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post! Reply With Quote #18 Old 04-22-2009, 08:06 PM Leeoniya Leeoniya is offline Junior Member Join Date: Apr 2009 Posts: 1 Unhappy i rewrote the script to act as a render switch button if anyone wants:

if you want it readable: Code:

javascript:( function (){ var lh = location.href; if (!lh || lh.match(/^(javascript|about):/i)) return; if (document.getElementById("_nept") !== null) location = location; else { var embed = '', html = '' + document.title + ' - using Internet Explorer rendering' + embed + ''; document.write(html); } } )();

compressed for usage: Code:

javascript:(function(){var lh=location.href;if(!lh||lh.match(/^(javascript|about):/i))return;if(document.getElementById("_nept")!==null)location=location;else{var embed='',html=''+document.title+' - using Internet Explorer rendering'+embed+'';document.write(html);}})();

click once to switch to IE render, click another time to go back to chrome. It just does a page reload, so you will lose any form info between switches. also Ctrl+T doesnt work when in IE mode.

i'd like to point out that the plugin is wierd. I expected it to use the IE that i have installed on the system, however this is not the case. they have a version of IE embedded in the dll file and the rendering is not like any version of IE...not 6, not 7, not 8. checked via Acid2 and Acid3. they must be embedding/using some different version of Microsoft Webbrowser Control. so this pretty much fails if you want to use it to stay out of IE for checking CSS issues within chrome : (

hope this helps someone, Leon Last edited by Leeoniya; 04-22-2009 at 08:18 PM.. Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post! Reply With Quote

share|improve this answer

Have you tried running IE in safe mode, thereby eliminating all addons and unnecessary garbage to see if IE works on its own?

click Start, point to All Programs, point to Accessories, point to System Tools, and then click Internet Explorer (No Add-ons)

share|improve this answer

Does it do this the first time you run IE? I noticed something similar when IE wouldn't close all the way, even though no IE windows were visible, but I could see one in the task manager -- when I killed the old one, the new one would work. But if it does it the first time you open IE after booting, that's not the problem obviously.

share|improve this answer

This could also be malware related. Some malware either hijacks DNS, or outright diverts you to other websites.

Grab a copy of Malwarebytes from www.malwarebytes.org and install it - best to run it in safe mode.

share|improve this answer

Internet options>Connections>LAN settings

Make sure there is no proxy ticked.

I also suspect it could be an addon problem. See if it happens with extensions off, run>iexplore -extoff

share|improve this answer

I having same problem. Cannot connect with chrome or Internet Explorer. Fire Fox works fine. It seems it happens when I was infected by a "Trojan Horse Generic 17.BWIK" and
a "Trojan Horse SHeur.UHL", when I reply to a post for a Thread I posted. I have removed the treat and got Fire Fox working but not GC or IE still cannot connect. I do not want to loose google History so resetting would be my last option.

share|improve this answer

I have IE9 and it would not open a link unless I right clicked and opened new tab. It was getting worse so I went to Tools → Internet options → Advanced → Reset IE to default condition. Works fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.