Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the OS X Terminal.app, I'm having some colour issues.

If I am working locally, there are no colours.

If I ssh into my opensolaris machine (using screen inside ssh) there are no colours.

If I then ssh into my ubuntu virtualmachine, and say, vim edit a file, the colours are completely broken. On quitting vim, it then keeps the broken colours and applies them to everything until I force a terminal bell.

I assume this is a misconfiguration of the ubuntu machines colours, or a mismatching of terminal emulators. What is the best fix in this instance.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

The easiest way to fix this is to run export TERM=vt100 when connecting to the Ubuntu machine. A good fix would be to find out what the value is supposed to be for Terminal and use that instead.

share|improve this answer
    
vt100 works, however it removes all colours. perhaps someone could recommend a term for use in osx/opensolaris/ubuntu to keep some consistency? –  Joshua Hogendorn Apr 14 '10 at 1:23
    
I use TERM=rxvt –  Josh Apr 14 '10 at 2:28
add comment

The easiest way/the way I do it is put export TERM=xterm-color in my ~/.bashrc, and colours work perfectly with my Ubuntu 9.10 SSH connections. (The problem is caused by Ubuntu assuming the terminal is xterm, not xterm-color).

share|improve this answer
2  
See i attempted this, seeing that xterm-color was the selection in the terminal settings, but i still get the same issues. Same broken colours (in the basic terminal i get yellows,pinks and blues on a grey background) which stick around on the prompt after whatever generated them (vim) has been exited. –  Joshua Hogendorn Apr 14 '10 at 5:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.