Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a multi-boot Windows 7 setup (32-bit and 64-bit) on my HP Notebook. Unfortunately, the Notebook screen has been trashed (due to my daughter dropping it). I have attached a second screen.

On the 64-bit system, after Windows has started, the logon screen comes up on the second monitor just fine.

On the 32-bit system, the logon screen still comes up on the Notebook monitor and I have to open the lid, then shut it so that it then switches to the attached screen.

Are there any settings I can use to force the OS to use the attached screen?

share|improve this question

1 Answer 1

Well, this is the second time I've posted a question on Superuser and found the answer myself in few minutes after! What a site! You only have to ask the question to find the solution! Geoff and Joel - are you taking note of this?

Anyway the problem has to do with how and when Windows detects the monitors. It turns out on my HP Pavilion that when the notebook lid is shut (and therefore the screen turned off) windows doesn't detect the notebook screen! So it sees only ONE screen - the attached one and makes it the ONLY screen on the Display control panel applet.

It seems that when I set up the 64 bit screen, the notebook lid must have been opened and so it saw both screens and therefor it saw a multiple monitor situation and allowed me to display the desktop only on monitor 2.

The 32 bit must have been set up so that only the attached display was available. The (unintended) consequence of this is that notwithstanding that it sees only one monitor, the attached one; when it boots, windows sees only one monitor and therefore starts up the notebook screen instead! (Hey man - you've only got one monitor - it MUST be the notebook screen right? (WRONG!)) You then have to go through the "palaver" I mentioned in the original question to get the attached display to be recognized!

However, if you have the lid open when you ask Windows to detect the monitors, it will see both and allow you to specify to only use number 2 and all works correctly.

Certainly somewhat counter intuitive! So I hope that helps someone else!

Paolo

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.