Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed ubuntu 9.10 on my laptop.

In System->Display, the best resolution I allow me to use is 1280x700. But my laptop can support 1600x900.

So how can i change it? I tried adding

xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync

and in /etc/gdm/Init/Default

But that does not help.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I've had this problem in the past as well. To fix it I just had to install some display drivers. To do this go to System —> Administration —> Hardware Drivers and see if there are any display drivers to activate.

share|improve this answer
add comment

I just had a similar problem with an old Dell Latitude C600, and found this link to be the solution, so a similar method with different numbers in the resolution section would probably work. It didn't automatically use the native resolution after a reboot, but the option did then appear in the Display settings dialog.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.