Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working on my systems without admin rights, but I'd like to start sysinternals process explorer as full admin to have some debug access on my machine.

Right now I run procexp.exe with parameter /e, which prompts me for admin credentials.

Of course I could use runas, but for this I would need to put my admin passwort in clear text in the corresponding batch file, which is something I don't like to do.

Is there a way to tell windows that this one procexp.exe is allowed to run as admin without needing to enter the credentials?
In Unix systems this is done using setuid (or setgid), but how can I achieve this functionality in windows?

share|improve this question
This sounds like a bad security policy to me. I hope Microsoft doesn't allow something like this. – surfasb Feb 15 '11 at 12:16
Every unix system allows something like this. There are ways to make this secure, and it is better than having to enter the password as plain text in a runas command. – Sam Feb 16 '11 at 9:59
btw. on unix this feature is called "set uid on execution". – Sam Feb 16 '11 at 10:14

There is Encrypted RunAs from, which is not free but cheap. There is an alternative (free?) project called CPAU, but it seems basically abandoned.

share|improve this answer
Seems like it would be easier just to write your own 15 line long Java or C# program that would do this job nicely. – djangofan Sep 28 '11 at 21:45
I would agree with that if this was Stack Overflow, or if the OP had indicated they were a developer. Non-developers read this site also. – Patrick S. Sep 29 '11 at 1:14
up vote 0 down vote accepted

I found an answer on Stackoverflow, which works for me:

runas (at least on xp sp3) has option "/savecred" - it asks for password the first time and then it uses stored one (even after reboot).

You need to be aware that this is a security problem, though: after you ran /savecred once, every executable can execute itself with these saved credentials without any problems!!

share|improve this answer

Right Click the Application shortcut -> Properties -> Compatibility and check "Run this program as an Administrator"

Hope this works and helps :)

share|improve this answer
It still asks for elevation, so no, it does not work. – Sam Feb 16 '11 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .