Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I love NetBeans and its auto-completion features. However, I wish the IDE stops suggesting variable names. For example, when I type "bool myVar" and a space, I ended up with "bool myVarB". The extra "B" suffix drives me nut. How can I turn off this behavior? I appreciate your help.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

If you go to Options and under Editor there is a tab for Code Completion. Uncheck auto pop up completion window.

If you need the completion window use Ctrl+space to bring it up.

share|improve this answer
    
Not sure he has a problem with the popup. –  Gnoupi Apr 14 '10 at 14:10
    
@Mark: Thanks for the tip. However, that disable too much. For example, it disabled suggesting of types (bool, String). As you said, Ctrl+Space will bring it up, but that key combo is currently used by Butler (a program launcher). I know that I can configure the hot keys, but I have reasons not to. So for now, I'm going to enable that pop-up and learn to live with it. –  Hai Vu Apr 14 '10 at 17:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.