Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Apple Mail frequently shows incoming messages in the Mail Activity window, but nothing will arrive in my inbox or any folders. Am I missing messages?

I'm now using OS X 10.6.3, Mail 4.2 but this also happened with OS X 10.5.8/9.

Should I be worried?

share|improve this question

6 Answers 6

A couple of things spring to mind:

Are there any messages in your spam/junk mail folder? These might be triggering the incoming mail message but then as they're moved straight away you don't see them.

Do you have any filters (or whatever they're called in Apple mail) active that move messages to other folders? This is less likely given that you state you've checked other folders. (I've seen this behaviour in Outlook for that reason.)

share|improve this answer

You probably have a corrupted Envelope Index. This can be corrected by deleting the index from /user/myaccount/library/mail or by going to Terminal and running the following command:

/usr/bin/sqlite3 ~/Library/Mail/Envelope\ Index vacuum

In both cases, you'll want to ensure that you quit Mail first. It also may help to choose "Rebuild Mailbox" from within Mail.app if you continue to have problems.

share|improve this answer

If your mail provider is gmail, then it's downloading emails from the "All Mail" folder. It has a copy of every email in your gmail account. When you send or receive an email, the email is received by gmail, it then copies it into the All Mail folder.

It is my understanding that if you use archive instead of delete, it also puts the emails in here instead of the trash.

share|improve this answer

If you leave copies of your emails on your email account provider's server, check to see if your mail box is full, i.e., you have used up your allowance.
If so delete some that you don't need (or archive them if you can) and this may solve your problem.

share|improve this answer

If your on 10.9 Mavericks the path is now :

/usr/bin/sqlite3 ~/Library/Mail/V2/MailData/Envelope\ Index vacuum

This worked for me.

share|improve this answer

I used the terminal command first it helped not, but when I run the rebuild option in the Mail app after it seems working now for me. MacBook Pro 15' OS X 10.9.3

share|improve this answer
    
Welcome to SuperUser. We pride ourselves on answers that provide enough detail to allow anyone to read them and solve the problem from the answer. Please expand your answer to include a few more details. –  David May 27 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.