Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i have a win 7 machine with an Atheros L1 Gigabit Ethernet 10/100/1000Base-T Controller with latest drivers, the machine is upto date with all latest fixes etc. I have it connecting to a WRT310Nv2 router. Seemingly random, win 7 disconnects from the "Home Network" says its in a "public network", then resets the connection to an illegal 169 address. I have tried static ips, dhcp, all with the same results. This seems to have started shortly after i installed Vuze, so I uninstalled it but the problem persists. I know that the router is sound given that I have an XP machine attached with no issues of connectivity at all. I am at a complete loss and have tried everything, pleasse tell me i'm not the only one.

share|improve this question
    
also I have reset the TCP stack as well with netsh –  Brandon Grossutti Apr 14 '10 at 20:35
    
That's weird. I'd say reinstall your NIC drivers too, while you're at it. –  goblinbox Apr 14 '10 at 21:14
    
did that as well –  Brandon Grossutti Apr 14 '10 at 22:29
1  
"Illegal 169 address..." I'm assuming you mean a link-local address? See en.wikipedia.org/wiki/Private_ip_address#Link-local_addresses for more info. I know that Windows will default to this address when it attempt to use DHCP and can't get an address. –  Dan Esparza Jul 9 '10 at 17:36
add comment

6 Answers

I would try working my way up the OSI model starting with Layer 1.

  1. Start with switching out the network cable.

With what you have said about trying everything, you probably did everything software wise. Most people don't think about changing out the cable. The copper wires in the CAT5/e cable could have been pulled out of the connector due to simple bending; or the cable could have been bent too much in one area, which would cause the connection to fade. With fiber cable, the cable can be bet very slightly and the connection will fade. I have had this happen at my data center before.

Good Luck -

share|improve this answer
add comment

OK I want to make sure I understand this, even if you set a static IP on that interface it will still reset back to DHCP and 169.x.x.x?

share|improve this answer
    
yes, its the oddest thing i have ever seen –  Brandon Grossutti Apr 14 '10 at 20:33
1  
First thing my mind goes to is some service or malware. If you boot into safe-mode with networking enabled does this still occur? –  Chris Disbro Apr 14 '10 at 20:46
    
havent looked in safemode yet, it is really random as well, sometimes will be fine for whole day then crap out, sometimes its every 5 minutes –  Brandon Grossutti Apr 14 '10 at 20:55
add comment

Is this the only NIC? In other words, is this a laptop with a wireless NIC as well as a wired NIC or a desktop with only wired NIC?

Does this happen when you connect to a different port on the router - preferably one you know is good?

share|improve this answer
add comment

I haven't seen the behavior that you describe, but you might want to check through the advanced settings for your driver in the Device Manager to make sure you don't have any power-saving settings enabled for the NIC.

I've seen a few cases where the NIC seemingly randonmly "goes to sleep" because it decides it's time to save some power.

share|improve this answer
add comment

Have you tried rolling back your system to before you installed Vuze?

I had a similar problem after installing Adobe CS3 on my system. It turned out that the bonjour service that was installed with the software was causing the problem. I disabled the service, reboot the machine, and it started working again. I personally hate Bonjour, but to be fair, it was a 2-3 year old version of it.

So make sure you have the latest version, and check for new services or startup commands that were installed with Vuze.

Hope that helps.

share|improve this answer
add comment

It can have relationship with UPnP. Windows 7 use it for discover network. Try use non windows firewall to block upnp, i think it is UDP packet port 80 and not authorized incoming connections.

Or you can try bootable linux distro. If it works it is not hardware problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.