Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

I think I'm going crazy. Every time I create a folder it automatically is set to readonly, but I can still then rename the folder or add folders to it. If I attempt to uncheck the readonly flag it becomes checked again when I next open the folder properties. What the heck? Could my IT dept really have set up a policy like this somehow? If so, how?

Seems crazy that Windows would even do this -- no errors when I uncheck read-only and hit ok but the change fails.

Also, it is the halfway checked state -- greyed out and checked, but uncheckable.

share|improve this question

marked as duplicate by Ƭᴇcʜιᴇ007, DavidPostill, Mokubai Jan 19 at 21:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Do you have ownership of the folder? –  Vervious Apr 15 '10 at 2:41
    
I've noticed this as well. Seems like all folders on my install default to this. –  mindless.panda Apr 15 '10 at 2:48
    
Yes I'm the owner –  Luke Apr 15 '10 at 2:48

1 Answer 1

up vote 7 down vote accepted

The actual read-only flag on a folder is used by Windows to mark that the folder has special customizations, but doesn't restrict write access to the folder or its contents.

When you look at a folder's properties, the read-only box will always show the half-way gray state. This means "don't make any changes to read-only flag on the files in this folder". You can check (or clear) the box to mean "make all the files in this folder read-only (or read/write)."

See You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Windows Vista or in Windows 7 for more info. If you really want to modify the read-only flag for a folder, it shows you how to use the attrib command to do that.

share|improve this answer
    
It doesn't work in ws2012 –  maxisam Dec 27 '12 at 19:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.