Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 Ultimate, and IE 8, and have the taskbar in icon view. I'm not sure how to explain this, but I'm amazed at how each tab in IE8 seems to act like a new "thing" in the taskbar (as if each tab was a window).

Like each tab acts like a different window in the taskbar although they are actually running in the same window. Now when I use IE 8 it looks (in the taskbar) like there's 15 windows open when in fact the taskbar is simply showing the 15 tabs.

More simply put, it's displaying a "stack" for all of the tabs when I'd rather have the icon act like, for example, Firefox so that a stack is only shown for the multiple windows.

Is there a way to disable this strange "taskbar" effect? I'd rather have the taskbar show the main window and not the tabs individually.

There has to be a simple way to do this.

share|improve this question
3  
Ironically, some people criticizes Firefox for not showing the tabs as individual processes on the taskbar like IE8, which means you can’t see the open pages without switching to the browser. :) –  Leonardo Apr 15 '10 at 4:50
    
@Leonardo: The task bar doesn't care about processes there. It cares about windows belonging to similar processes and you can make that distinction for your own as a developer (for MDI or tabbed interfaces for example). –  Јοеу Apr 15 '10 at 5:03
    
Thanks, Johannes, I didn't use the right word (I said processes to match the language of the question.) –  Leonardo Apr 15 '10 at 5:06
1  
Ah... I should probably change the language of the question. –  Vervious Apr 15 '10 at 5:22
    
@Leonardo You can enable and disable this in FF, just as you can in MSIE. –  kinokijuf Mar 6 at 15:04
add comment

1 Answer

up vote 48 down vote accepted

See "How to Disable IE8/IE9 Tab previews in Windows 7 taskbar"

To disable IE tab previews in taskbar, just open Internet Explorer > Tools > Internet Options. Open settings for ‘Tabs’ and uncheck the box saying ‘Show previews for individual tabs in the taskbar’. Click Ok and restart IE for letting changes to take effect.

This solution will work for Internet Explorer 9 as well.

share|improve this answer
    
It worked perfectly. Such a simple solution. I probably should have Googled a bit more before on asking on SU. :) –  Vervious Apr 15 '10 at 5:05
2  
Nah... asking it here is the point so that it helps SU grow and helps everyone like me who comes here first to look for answers. It solved my problem; +1 for the question and for the answer. –  I Have the Hat Sep 8 '10 at 14:39
1  
Works for Internet Explorer 9 too. –  SgtOJ Mar 21 '11 at 0:14
    
@brian Your suggested edit was rejected because it would have been more appropriate to update the answer since the source has also updated its information for IE9 –  random Mar 21 '11 at 0:21
    
This still works 4 years later in IE11 (under Windows 7 at least anyway). :) –  techie007 Mar 6 at 15:01
add comment

protected by slhck Jul 29 '12 at 17:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.